Missing time mark in M+

Hi people, since the update to firmware version 28.4, with my m+, my time mark trigger with the PPK-kit is not working. Anyone know how I can check this?

Hi Remco,

It shouldn’t be related to the latest firmware as we didn’t change anything in the time mark recordings mechanism. Have you double-checked the connection between Reach M+, hot shoe, and a camera? What GNSS settings have you configured for M+?

Hello! I am working with a PPK-kit, the time mark is triggered by the lights, since the update, it is no longer working. Maybe I have to change the settings, please see enclosed the GNSS settings





Hi Liudmila.slepova, any ideas about a possible solution for this?

Hi Remco,

Thanks for sharing the screenshots!

When selecting GPS + GLONASS + Galileo + SBAS + QZSS, we recommend setting the update rate to 1 Hz. If you want to work with a 5 Hz update rate, you can select GPS + GLONASS + QZSS or GPS + Galileo. You can check the list of recommended settings in this guide.

OK, I will try and see if this makes a difference for the time marks. Is there any way to test the time mark triggers in the settings?

Hi Remco,

You can connect Reach to a camera in the simple hardware setup without the drone parts and trigger the camera several times. Then, check how many time marks were recorded to the raw data log. It should be equal to the number of triggers.

Well that’s nice, but I don’t have a camera with a hot-shoe connection

Remco,

Can you please describe your hardware setup with Reach M+, then?

Thank you, yes, I am using a PPK kit, this one: PPK KiT for Phantom 4 Pro & Advance - METTA Technologies - the time mark is triggered by the front LED of my Phantom 4 Pro V2

Remco,

Oh, I see. I can hardly say how to check the time marks recording with this assembly since it’s a custom setup. We recommend using the hot shoe cable with Reach and the camera as this is the only setup we can confirm
that it’ll work. Have you tried contacting the support of the company that provided this setup? Maybe, they will suggest the best way to check this.

I have contacted the support of the supplier, let’s see if they are able to help. I am sure there is something wrong with the time registration of my Emlid, where can I find the time registration settings? (I have updated the device to the Beta 29.1 today, without a result unfortunately)

Hi Remco,

You can find the settings for the camera on the Camera control screen. Connect to the receiver in ReachView 3, tap Settings, and scroll down the screen. Camera control will be at the bottom of the screen.

Regarding the 29 Beta 1, it doesn’t contain any changes for the time marks mechanism so it won’t have an effect on your current configuration. We recommend using stable releases for any major work since Beta mainly aims to give early access to new features.

Thank you, is there a way to downgrade the device? do I need to use the firmware tool for this? Please see the screenshots, where can I see the settings for the time mark mechanism?


PS: the screenshots are taken inside a building, I know I need satellites in view to have a time registration…

Hi Remco,

Sorry for the delayed reply!

You can roll back to the stable in the General Settings screen. There will be the Roll back to stable version button. Here’s the part of the guide that contains the step-by-step instructions.

Here you can configure the camera trigger from the Reach device’s side. By altering the duty cycle and period parameters, you can match the settings required for triggering your camera. But usually, the camera is triggered by autopilots. Those settings are configured in the flight plan on GCS applications. So, you can tune the setting in the Camera control screen only if your drone’s camera is triggered by Reach.

After a long search for the cause of the error, I’ve found out why there was no time stamp. The root cause of the problem was a defect sensor, the Emlid software had nothing to do with it. Sorry for wasting your time, thank you for the support!

1 Like

Hi Remco,

No worries, I’m always happy to be of help. Glad to hear that you’ve found the solution for this!

I’m closing this thread, then. Please feel free to create a new thread if you have any other questions.