Missing Log Files

Hi, in version 2.7.0, when recording raw data the last raw data file is deleted if the reach is powered down after the logging has been stopped and saved. We use this feature to record raw position data for our UAV ground control, we leave the reach on during the capture process, only logging when the reach is set on the ground control. The last log is always missing when we power up the reach back in the office. We get around this now by quickly recording another small log before we shut down the reach after collecting all our ground control points. I can confirm it happens when logging just UBX as well as UBX and a Rinex.

Do not seem to have that problem here.

Do know that if I do not stop logging before shutdown, the boot up is lengthened while log files are being processed and I may have to reboot. Once I stopped logging and waited for log files to be processed, then boot up seems to go better. Does not quite seem to be what you are experiencing.

The UBX file is compressed into the RINEX log file.


We’ve tried to reproduce your issue and failed miserably. Does only the UBX log go missing, or both UBX and RINEX?
Also, please share your settings.

Same issue here, no ubx log in rover to download and get timemarks after flight complete. Everything was working fine in later versions…

Hi Igor, yes both files are removed.

Here I recorded some test logs.

I then shut down the Reach, waited a few seconds then rebooted to again reveal the last log 00:03 has gone

Here are my settings

I had also faced the same issue before I reflashed my reach units yesterday. The logs window on one of my units which I had designated as the ‘base’ did not show any of the logs that were recorded. When I turned on the logging by toggling the raw data switch, the corresponding log file name would appear in the list. But, as soon as I turned the recording off, the file was not visible in the list. :thinking:

My workaround was to download the log and then disable recording. Since this was the base unit, I had to do the operation only once, and it was not a big hassle. I also tried SSHing into the reach to retreive the logs and it was possible. The log files were present. I can’t post any pics as I just reflashed my units yesterday. :man_shrugging:

Thanks all for posting. I had the same problem on a couple of flights, just assumed I was stupid and not turned logging on. I will SSH in and see if the files are there.

I am still having this issue and it seens worse. Now some of those missing logs, which I was reaching with SSH (they didnt appear on ReachView), are completely empty. Those are files that I was recording and monitoring the time events with ReachView while the data aquisition.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.