Mavros Start Error - egm96-5.pgm Not Readable

With latest Emilid images (20190227), I am following this procedure to launch Mavros but get the following error:

[FATAL] [1551290546.061924061]: UAS: GeographicLib exception: File not readable /usr/share/GeographicLib/geoids/egm96-5.pgm | Run script in order to install Geoid Model dataset!

I did the following steps per procedure:

echo “source /opt/ros/kinetic/setup.bash” >> ~/.bashrc
sudo /opt/ros/kinetic/lib/mavros/
rosrun mavros mavros_node

I even reinstalled geographiclib by issuing the following command again but made no difference:

sudo /opt/ros/kinetic/lib/mavros/

I even tried to reinstall geographiclib-tools using the following but made no difference:

sudo apt-get install geographiclib-tools

Any ideas?

Thank you

Some more information…

When I issue the following command …

sudo /opt/ros/kinetic/lib/mavros/

I do get the following:

Installing GeographicLib geoids egm96-5
Installing GeographicLib gravity egm96
Installing GeographicLib magnetic emm2015

But there is nothing in the following folder:


Does this mean that install did not work?

Do you need internet connection to install?

Hi @vnpathak,

Yes, the Internet connection is required. Check out Navio2 docs to connect RPi to the Internet.

Solved by connecting to internet. I only had it connected directly to PC which did not provide Pi an internet connection.


1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.