Mavlink with 3DR radio not working

I’m all set up and if I use UDP from mission planner all works fine but I want to run 3DR radios for telemetry and mission planning but although it would seem that the command “sudo ArduCopter-quad -C /dev/ttyAMA0” starts APM I’m unable to get a connection using the radio

Any suggestions would be good as this is stoping me from going any further.

One last thing on which device do you run “pip install mavlink mavproxy console wp” as this fails on the rpi


Hello Andrew!

The device you run the mavproxy onto depends on the thing you’re trying to achieve. If you want to use as a GCS, then you launch it on your host. In order to fix the error, you need to install python-pip package.

Could you please elaborate on the problem with radios. What GCS do you use? If you use Mission Planner, you can try to look into the problem in the SiK section.

As I mentioned in the post I’m using mission planner and 3DR 433 radio link but mission planner just times out. The 433 telemetry radios work fine on a pixhawk. But I will look into sik section. I’m assuming that it should just work. UDP is fine but I don’t want to use that method.

Which version of the telemetry radio do you have? The newer ones, where the units have micro usb and UART connectors? Or the older with one ground (USB) and one air (UART) module?

New ones USB and UART :slight_smile:

Did you try to connect the radio to usb and start with -C /dev/ttyUSB0 ?


No I didn’t. Not seen that command in the documentation. So on the navio2 conect the radio to rpi usb? Or keep it in UART and run your command? At the moment it’s plugged into UART on the navio2 as shown in their docs and the PC end is USB.

Like so, except for a USB A to micro USB cable between the radio and the Rpi:

1 Like

Sebastian thank you so much. This is the one thing I don’t like about open source lots of development and production costs to make probably the Navio2 one of the best platforms but let down by documentation and or clear instructions. However I am new to this way of working and have been spoiled with plug and play. On too the next step rtklib I think.

Thank you very much.

Sebastian does that now mean the UART port can be used for something else?

I take from your reply it is working with USB?
To get the UART working, start:

sudo raspi-config

and then under

“Advanced Options”




By default there is a user console/login shell active on the RPis serial port, so it is not available for data transmission. With choosing “No” you do not disable the serial port, but only the console.

Did you solve your problem with mavproxy?
If you plan to use only the 3dr radios for telemetry, there is really no need to install mavproxy on the RPi.
Mavproxy is really handy to manage multiple telemetry connections and it supports udpci, where the udp telemetry stream gets send to the client requesting it. Even to multiple clients on the network. If you still want to install it you will need to install the following:

sudo apt-get install python-pip python-dev

then run

sudo pip install mavproxy

pip resolves any dependencies for mavproxy by itself, so there will be installed more than just mavproxy.