Mapit GIS precision issue


I have been fighting with the new reach view app3 for a few days and have resolved most of the issues I had. Now I come to marking ground points using Mapit GIS and I cannot achieve the accuracy I need below approx. 4m I have a FIX. situation with the emlid and a good estimated accuracy from the status overview. Also, I cannot zoom in on the Mapit beyond what is shown in the image. I assume this is due to the precision! Can anyone offer some advice? Do I need to configure anything within the mapit settings? Thanks

Hello greencurvesdesign

Have you configured Mapit GIS as per instructions ?
I think you are using Mobile internal GPS instead external GNSS via Bluetooth link.

Hello max3design,

Yes, I have it set correctly to the external GNSS. I will check and make sure. I was looking at the left image above where it states that there are 26 satellites in view but next to the green ‘Fix’ signal in the top right corner there is a number two next to it. What relationship do these two numbers have, if any?


If you click on the satellite icon inside Mapit GIS, you can see if you are connected to external GPS like caption attached (i am inside so no fix solution)…

Next sample is Smartphone GPS

Hi Bruce,

I am a little out of the loop with the Mapit GIS settings. But I also have an assumption that Mapit GIS probably uses your phone’s GPS data. @max3design beat me to it :slight_smile:

So it’s better to double-check all the settings. I’d suggest checking our guide about Reach connection to the GIS apps on Android via Bluetooth as well. It describes the main steps of setting the connection to the GIS apps, including Mapit GIS.


Good morning,

Thanks for all of your comments and support. My problem was that I failed to pair the rover via bluetooth to my android device. I was only paired to the base. As you can see, everything is good :clap:t2: :clap:t2:


This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.