M2 NTRIP base via emlid caster (network problem?)

Hi,
I have set the M2 acting as NTRIP base station with emlid caster. I use an old 3G mobile phone as hotspot to connect the M2.
The Lefebure Ntrip client on my phone that uses other sim card connects to the mountpoint and shows that it receives the corrections from the base.
My problem is with the rover (3rd party hemisphere P40 board) that although it seems to receive the corrections it shows “Single” not even dgnss or float. The rover uses another sim card that connects to the internet.
At first I thought that the rover couldn’t recognize the MSM4 messages the M2 broadcasts but at some point i did a test in which the rover and the M2 was getting internet from the same hotspot. In that test the rover got the corrections and fixed immediately so I am sure that the rover “reads” the MSM4 messages.
So in short, if the M2 and the rover are in the same network the NTRIP base-rover works fine.
If the M2 connects to a hotspot via sim1 and the rover connects to another network (via sim2) then the NTRIP doesn’t work.
Can anyone explain why this is happening? I know that the problem is not related to emlid but my my knowledge of networks is limited and maybe you can help.
Sorry for my poor English, I hope you understand the question.

I did some more tests, and the M2 works as it should. All the settings are correct and the rover although it receives the corrections it stays “single”.
On the emlid caster page shows that the rover is connected to the base station.
It must be something with on the rover side, maybe the rtcm3 protocol. I must contact the manufacturer to check the problem.

Hi @vgo195,

I can hardly be of much help with questions regarding 3rd-party devices. However, as far as I can understand, the issue is related to the SIM-card. I’d suggest clarifying with the manufacturer which technologies the rover supports. I mean, GSM, 3G, etc.

If you face some difficulties with Reach M2 or Emlid Caster, please let me know.

Hi,
I managed to work with another caster. I sent the emlid M2 corrections to that caster and the rover received the corrections immediately and fixed the solution.
So I come to the conclusion that the sim carrier must have some restrictions. Both emlid caster and rtk2go caster doesn’t work for my current setup but the other caster works.
I think I must consider changing that network provider.

Hi @vgo195,

Glad to hear that you’ve found the solution.

However, I’ve never heard that SIM-card can have restrictions on sending the corrections via NTRIP. If you wouldn’t mind sharing a bit more info, we’d like to investigate it. Could you clarify which SIM-card you use? Which caster helped you solve the problem?

Both SIM cards are from vodafone. They are data-only sim cards.
I don’t know if the restrictions are on the base side or on the rover side because the base seems to be sending the corrections and the Lefebure NTRIP client (NTRIP testing mode) can connect to the mountpoint and receive the corrections. Before you launched the emlid caster I was using rtk2go and I had some problems with an older sim card on the base side.
The caster I used without problems was provided by the hemisphere rover brand. I don’t know if I can share the brand publicly.
If you want I can send you pm.

Hi again,
unfortunatelly the provided caster worked only once.
I did some more testing and the rover didn’t work this time with this caster.
I would like to ask if there is some ntrip testing mountpoint on the emlid caster. This would help me to troubleshoot the problem.
I really like the emlid caster functionality and would like to have it in my workflow.
I think it must be network related problem but I don’t know which one has the problem. Is it on the base side or in the rover side?
If you have some testing mountpoint please let me know!

Hi @vgo195,

Thanks for keeping me updated!

We don’t have open mount points for testing. However, you can check if the base sends the corrections to the caster on the Emlid caster page. If the base is connected to the caster, its status changes to Online. Could you check that and tell me about the results?

I did check the emlid caster page and both the base and the rover was green (online).
But on the rover nothing happened, nor float or fixed only single.
I will try to connect both the emlid base and the rover with another cell network to check if the problem remains and I will report back.

P.S. I did some testing with open mountpoints that rtk2go provides just for testing. I selected only the ones that send MSM4 GPS+GLO+GAL+BDS streams and the results were some of them was working and I was getting a float solution and some of them was not working and I was having again single position only. So I couldn’t come to a conclusion what’s the problem.

Hi @vgo195,

You’ve previously mentioned that there are no such issues when both the base and rover are connected to a Wi-Fi network. Is that still so? Does the issue repeat with a SIM-card only?

I am not sure yet.
Please give me some time to do some more tests.

Sure! Thank you for testing and keeping us updated.

Hi again,
I did another test today.
I setup the emlid M2 base with emlid caster. The M2 was connected to my home wifi.
Then I go to the field and connect the rover to my mountpoint but again it didn’t work.
I also did another test with a colleague’s gnss receiver by Kolida based on bd970 board and it also didn’t work. It showed that it received the corrections but it stayed single like it was not using the corrections. Also he was using another cell carrier so the problem wasn’t the cell carrier.
The lefebure ntrip client also connects to the emlid caster and receives the corrections without problem.
So my conclusion is that the emlid caster works fine but there is some sort of incompatibility with 3rd party receivers. Both receivers use surpad data collection software but I have also tried survCE with the same result.
The big question for me is how it did worked 2 times? It is really strange.
So I’ll wait for the next emlid firmware update to check if it works.

Hi @vgo195,

I got you. I’ve collected all the info you’ve shared. We’ll check what might be wrong. I’ll get back to you with the results.

Please let me know if something changes.

Since I am not able to use the emlid M2 as base station in my current setup I thought to use another base station to pass the corrections to the emlid caster.
The problem is that this receiver doesn’t have ntrip server built in.
I have found a nice general purpose app for android called GetBlue that can receive and transmit messages from various sources to various destinations.
It can read the corrections from the receiver via bluetooth and I want to send them to the emlid caster. GetBlue doesn’s support natively the Ntrip protocol but it supports sending the stream to HTTP server.
Since Ntrip is built based on http can I trick the app to act like ntrip server?
The app can also send commands to the server.
I tried to set the required fields but no luck.
It has some Data and Timestamp parameters and also type of request (GET,POST) but i don’t have the knowledge to configure it. Maybe with some commands?

Hi @vgo195,

Do you know which RTCM3 messages are required for your Hemisphere P40?

I see your tests with the GetBlue app, but I think using another software in the setup might hamper our investigation. Let’s try to check what’s wrong with sending corrections via Emlid Caster.

Hi,
as far as I know Hemisphere P40 works with any message type RTCM3, RTCM3.2, MSM etc.
It is a 2020 board so I think it will work with every message type.

As far as GetBlue is concerned i think i have found an alternative solution that works. So you can ignore the GetBlue related question.
Thanks again for your help.

Have you tried to switch base and rover roles? I mean connect Hemisphere as a base to Emlid caster and receive corrections on Reach M2.

No I haven’t done this yet. It is in the to-do list.