M2 not reliably creating Hotspot

I have been using a Reach RS2 and M2 on and off for the last couple of years.
I have used the M2 on its own and integrated with a Raspberry Pi 3b.
At an early stage I had identified that the M2 was current hungry on start-up and if a sufficient power supply was not available then Inconsistent boot ups would occur.
I thought that I had solved this problem using a battery 6Ahr and a PiJuice UPS hat to supply both the Pi and M2.
Recently I came back to the project and found that the M2 was booting unreliably again.
I did some tests on my original M2 and a new one that I had more recently purchased.

I separated the M2 from all of the other components in the project. I found that using a standard USB power supply, the M2 would behave differently when booted by plugging in the USB power supply in the presence or absence of a WiFi network.
This is expected as the M2 tries to connect to a known WiFi network before it turns on it’s WiFi Hotspot.
However, when there was no other WiFi network available, the M2 would would turn on it’s hotspot and then not get past the green flashing LED which the Emlid Docs say is “Time Sync”.

I could connect to the Hotspot, but the flashing time sync seemed to be preventing Reachview from seeing the hotspot.

If I booted the M2 in the presence of a known WiFi network it would, then it would connect to that network and after a short time the green LED would stop flashing and stay on. Then Reachview would be able to see the M2 and connect to it. If I then set the Hotspot switch on the M2 via reachview to ON, I would be able to connect to that Hotspot and after the green LED stopped flashing, Reachview would see the M2 and would connect.

I checked the forum for similar issues and found that a number of people had had problems in the past with the Green LED continuing to flash. This had been fixed apparently by a firmware Upgrade.

I checked my newer M2 and it showed the same functionality.
Both M2’s are running Firmwear V27.1
I am using Reachview3 V6.9

Can anyone shed some light on what is going on here?
My original intent is to have the M2 setup a hotspot, so that Reachview will connect to it directly and in the absence of other WiFi networks. The M2 is booted and stopped by turning the power On and Off.


The M2 does the time sync either via GPS or wifi network. If neither are available, it will not sync would be my best guess.

1 Like

Hi Rodney,

Welcome back to the forum!

Thanks for the detailed explanation of your workflow. That helps a lot!

You’re right to mention that Reach M2 is current hungry. I wouldn’t put it this way, of course :sweat_smile: but it can be close: power requirements for M2 are stricter than for M+.

This is not the reason for the behavior you’re experiencing, though. Reach M2/M+ have to sync their time before they can be visible in the app. As @jp-drain-sol rightfully mentioned, there are two ways to do that: through satellites or via the Internet.

So your units have to have the GNSS antenna connected and the sky visible every time you turn it on. Alternatively, it’ll work just like it does for you: once the unit connects to the network with Internet access, it syncs the data. In both ways, the finish of this procedure is shown with a solid green LED.

So, the unit will be turning on just fine without any external networks if it sees the satellites. Just a quick tip here: it’s usually better and safer to switch the unit off in the app. That’s just a way of protecting the data on the units.

1 Like

Thanks both @jp-drain-sol and @polina.buriak.
I did not mention it, but the tests I described either did not have sky access or did not have the GNSS antenna attached. I can now move on and go back to checking my power supply with confidence.

In regards to turning the M2 off by just turning off the power, apart from possible damage to data stored on the M2 am I likely to do any physical damage?
The reason is that in my project, normal operation does not involve the use of Reachview.

Thanks again for your assistance.

Hi Rodney,

Got you! Tell us how it goes when you go outside! Or put the unit closer to the window :slight_smile:

Also, I don’t think you can cause any real damage to the unit if your power supply falls under the specs. Still, it may be useful to remember that your unit can’t turn off immediately, that’s why there always will be some time before it can turn on again. This time is different for all units, generally staying between 15-25s, but it requires testing in your setup.

Thanks @polina.buriak. I have tested my original M2 connected back into my project and with sky access. It boots and after a short time establishes a time sync, solid green led. My rPi can then see it s data stream on usb. So that is a problem solved.

I did not see the M2 setup a hotspot as I expected. blue led flashing slowly. I thought I was out of range of any WiFi networks. If there is a weak wifi network, will the M2 preferentially try to connect to that against setting up it’s hotspot?

Can you expand on

The only way I can see to do a controlled shutdown is to do it via reachview. Under normal circumstances I will not be using reachview and only currently have the ability to turn the power off to the M2 when I turn off the rPi.
I don’t think there is an issue for me if I have to wait before I turn it back on.

If it is available, yes it will connect. Either move out of range or in the settings, forget the network.

Never had issues with power down. If it is an issue, doing it through RV3 is very easy.

1 Like

Thanks @jp-drain-sol. I will try telling the M2 to forget any remembered networks.

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.