M2 Firmware Update Failed

Hello.
I’ve been trying to update my M2 since yesterday.
The message that appears is:

I’ve tried using the APP and the PC.

Attached the full report

Hi Mauricio,

Let us check if it’s reproducible. I’ll keep you updated.

Hi Mauricio,

Couldn’t reproduce it. Maybe there are some issues with the Internet connection? What do you use as a Wi-Fi?

Hello,
Apparently the internet is fine.
I can connect the smartphone, I can connect TV, computer…

I have fiber optics and I distribute wi-fi through two radios.
M2 is connected to the closest one, which is 10cm from M2.

Hmm, do you use this network with Reach on regular basis?

And just in case, do you have another network to try?

Hello.
I tried again.
I tried on another network.
I tried on the cellular mobile network.
Nothing solves.
I’m unable to update my M2.

Mauricio,

Let me take a closer look at your system report. I’ll get back to you soon.

And I’ve removed it from your post as it may contain sensitive info. Sorry for not doing it earlier.

If you can, please share the logs from the Flasher too. On Windows, you need to do the following:

  1. Press Win + R
  2. The Run window should appear
  3. Paste this string into the Run window: AppData\Local\Emlid\Reach Firmware Flash Tool\logs

It should open the folder with flasher logs. Please zip the folder and send it in.

Now, my M2 appears only with a constant red LED on.
I can no longer access it.
I’ve unplugged it in an attempt to restart, but nothing works.

The same thing happened to me with the update of a module, after the update to 29 it restarted fine, but after I turned it off it kept the red led and there was no way to restart it.

The solution was to download the update manually and flash it.

But I can no longer access the M2.
How can I update manually?

@mauricioranzan

I tried this,
gives error

Follow report
reach-flasher_619c131f16b9423dad47d0323846aecf_windows-10_26.07.2022_14-51-49.zip (7.0 KB)

I don’t know if it is allowed to post the direct link to download the Emlid server update.

Check with support for them to provide it.

It is safer to flash it with the previously downloaded file.

Hi there!

We managed to reproduce the issue and just fixed it in 29.1. Please reflash your devices to this version. It’s already available for automatic download in the Flasher tool.

If you face any difficulties, please let me know.

Hello @svetlana.nikolenko ,
I managed to reflash my M2.
Now it seems that everything is working normally.

Many thanks to the forum colleagues and the Emlid team who promptly answered me, both through the forum and through the contact via email.

Big hug to all.

1 Like

Great news! And thank you for the kind words :slightly_smiling_face: