M2 doesn't turn on after updating to 29 Beta 2

Hi svetlana.nikolenko,

Beta 29.2 update on M2 module once updated and rebooted is stable LoRa.

But once it turns off and on again only the orange led turns on.

There is no way to restart, I changed the cable, I changed the power source of other modules that work with stable version but there is no way to restart.

I did a reflash to a stable version and it worked again.

I did an update to the Beta 29.2 version again and I still have the same problem described.

I return to the stable version and the reboot is solved.

1 Like

Hi @JAGUERO,

Thanks for this report! We didn’t face it on our office units during testing. But we will check once again and try to reproduce this.

1 Like

Hi @JAGUERO ,

Just to get more details from your feedback, was the M2 connected to its GNSS antenna, and was it tracking signals - ie. was it outside, when it failed rebooting ?

1 Like

Hi @Florian , @svetlana.nikolenko,

The test is carried out connected to the antenna and in the open sky.

The update to version 29.2 is successful and restarts automatically.
In fact, I was able to verify that the stability of the LORA module was resolved.

The problem is after turning it off and starting it days later, it does not start, it does not go past the orange LED, it is not the power source, I made several changes of cables and power sources and it does not start with any.

With the reflash to a stable version it is solved.

The issue is that the stability of the LORA module has problems after the obsolete version 24.2 and so far with 29.2 it comes to solve this stability.

Hi @JAGUERO,

Thanks for these details. We’re still trying to reproduce this. Once we have any news, I’ll post them here.

I also wanted to add that the fix for LoRa will definitely be included in the next stable version.

1 Like

@svetlana.nikolenko

I have verified that stability has been fixed for the LORA module in M2 with stable version 29.

The module kept it in the obsolete but stable version 24.2

I had to do it in several steps since it does not show the direct update to 29.

First update to 28.4 and then to 29.

Everything went fine, updated and rebooted.

But when you turn it off and restart it, the red led remains fixed.

The solution was to manually download the update and flash it.

I have read other similar cases that after updating it does not start and they must flash it, including RS2.

Hi @JAGUERO,

Thanks for the news! After your report, we found the issue’s root and fixed it in just released 29.1 firmware version. It was released in a couple of hours ago. From now on, you can update your device via ReachView 3, and this should work fine.

1 Like