M2 and Pixhawk Cube with Here3 not working

I have read alot about connecting the M2 to the Cube and tested different hardware configurations as well as followed the Emlid Arduino Guide. NO luck with M2 on GPS2.

Do both GPS devices have to have the same protocol, ie. Serial or CAN? I cannot change the Here3 to Serial or IC2, it only has CAN BUS. The Here3 works fine on the CAN1. But I cannot get anything from GPS2/M2.

I have been at this for days, this is terrible. Any help would be appreciated. ???

Hi John,

Do I understand correctly that your Reach M2 correctly receives the satellites’ signal but you can’t receive it on your Pixhawk?

Please make sure that you have the following parameters set in the Mission Planner:

  • SERIAL3_PROTOCOL = 20 (NMEA Output)
  • SERIALL3_BAUD = 38 (the baud rate set up in RV)
  • GPS_TYPE2 = 5 (NMEA)

It’d be great if you could share the photos of your hardware setup so that we could check it.

I don’t have a Here3, but I ran on a similar issue with Here2 running on CANBUS. Take a look at this thread HERE 2 Pixhawk CAN issue (Solved) It might not solve your issue but it will help you understand the reason why it wont work. I recommend you get your hands on a HERE2 and work from there, Emlid is a great system, they just need to update the way the system works with the new CANbus protocol.

Happy Holidays!

Sorry for the so late reply, hopefully you have solved your issue.

Thank you very much for the response and link. I will check it out and post my results when I get some time to look at it again.

Happy Holidays!!!

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.