M+ as second GPS on PIXHAWK4 running Ardupilot - no data

I am having problems getting NMEA over UART to my Pixhawk4.

I initially had some wiring troubles but managed to get an RTK fix position in Ardupilot.

But I was getting 99 Hdop on my GPS1 so I rolled back the settings to default and have not been able to get it working again. I have tried making new cables, tried different baudrates, powering the M+ through various means.

I dont know if this would affect the serial port but now I cannot use the USB port on the M+ i will not power and my PC says there is a power surge?? Have I managed to short something during my experimenting?

The base is setup as per the emlid integration document over TCP, RTCM is being streamed from the MissionPlanner.

I have made a cable which connects 2RX-5TX / 3TX-4RX / 6GND-1GND using 6pin connectors between UART port (PX4) and S1 port (M+)

Power for the M+ is supplied via a 5v SBEC connected to port C1 (pin5 +5v pin1 GND)
GPS autoconfig 0
GPS type2 is set to NMEA
GPS inject is 1
Serial4 is on 38 baud and protocol is NMEA

Both Reach Base and M+ Rover are setup as per the emlid integration doc.
M+ corrections over UART and M+ position over UART (NMEA)

I need to confirm that I am actually getting serial data through the S1 port - how do I do this?

Hi Fin,

Thanks for the detailed description.

Please try powering Reach M+ via the USB port using a different power source (e.g., power bank). This will help us to check whether the unit can be turned on properly first.

Also, please specify what the red LED status is when you connect M+ via UART.

Status of red led is on.
I can power through C1, S1 and S2 power pins using a 5v dc power supply. the USB will not power up for some reason. and if i plig into a pc i get a message saying power surge on usb port!

(unit is not powered through the other pins when i try to connect usb)

Hi Fin,

Thanks for the details.

Usually, there are two reasons why the USB port might not work:

  • unstable or unsupported power source
  • broken USB-cable

Please, connect Reach M+ to an alternative power source like a USB wall adapter using a different cable. This will help us to eliminate the external factors that might cause this issue. Keep me posted on whether it works for you.

Let’s also cross-check these settings for M+ configuration as GPS for Pixhawk. Just to make sure that everything is set up correctly.

Position output of Reach M+:

  • Device - UART
  • Baud rate - 38400
  • Format - NMEA

Mission Planner settings:

  • GPS_TYPE2 = 5 (NMEA)
  • SERIAL4_BAUD = 38

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.