Emlid Reach RS2+

I’ve noticed since adding a sim to my RS2+ that LTE does not automatically turn on/activate at start up. I have to go to “reach panel” turn on Mobile data each time. Anyone have same issue? Not a big deal, but would like for it start automatically.

Hi Brad,

Which firmware version is installed on your Reach RS2+?

I have to go to “reach panel” turn on Mobile data each time.

You can turn Mobile data on and off in the Emlid Flow Mobile data section:

Is there any specific reason why you’re working with it via Reach Panel?

I’m on Version 29.2. I see the button to turn on/off mobile data in app. It hasn’t been working. I just tried it again and it worked. Strange. Going into field shortly and will test again.

Hi Brad,

We’ve done some tests with a Reach RS2+ on 29.2 to see if we can reproduce the issue. After inserting a SIM card and adding APN settings, mobile data was turned on fine in Emlid Flow. And after a reboot, it was still active.

Did you get a chance to do any additional tests? Does the mobile data stay activated in Emlid Flow now?

Sorry, forgot to report back. It seems to be working still. Not really sure what was happing initially. Maybe just me. Lol


Glad to know it works! Thanks for the update.