Losing fix after 20 min

Hi. I have a problem with every setup I use. I was the same at old reach and also at new GUI.

At actual setup I work with gps only.

My base is connected with ntrip server 25 km away. The base is able to hold rtk with gps only for hours.

At my rover it’s always the same. For this setup rover is static and not moving.
After 5-10 minutes rover gets fix stats. Ar is growing to 999.
After that ar ratio is decreasing slowly down and down the next 10 minutes.

Then the ratio is always between 1 and 2. I never get back fix status.

Can you please share your logs? Why do you use GPS only?

i use a ntrip server to fix my base position 25 km nearby.

i did try this:

  1. gps on (fix and hold) glo on (ar mode on)
  2. gps on (fix and hold) glo on (ar mode off)
  3. gps on (fix and hold) gps off

with 1+2 i got a fix solution but i was not stable like a mention in the post before.
i also got not the same fix solution every new run. ~ ± 1m

with 3 fix was stable for hours and anytime the same postion.

if i have time i will record different logs sessions with my rover and post it here.
but i dont think that is an emild issues its on rtklib…

regards andreas

ortner.zip (1.6 MB)

here are my data sets according to the last post.

best reagards

Thanks Andreas,

Do you think you might be able to find the raw data logs from the base? You have the incoming RTCM3 logs on the rover in the files, but I would like to check them against the raw data log stored on the base.

Ok, logging is not on at base. I will record a new session and post it.

Best regards Andreas


here a new data set inkl. basse

reach.zip (1.9 MB)

another data set. rover stationary 10 m baseline - 3 m on roof.


ps. did send you pm for login…

this is a comparison between reach (beta and 2.4.3 b26 and beta from rtklibexplorer



Have you tried the recommended settings from the docs?

I would re-run the post process and see how that affects your results using those settings.

If you’re able to obtain a reliable fix in RTKPOST it’ll help you figure out what setting changes you need to apply to keep your fix in the field.

i did try everything.

i don´t know why it´s hard to get and hold fix under best conditions in static mode (no moving) with beta.

when i postprocess data i get better solution.

with old reach view i had also the same problem losing fix with best conditions in the middle of a field.


i think tim has found the problem…

1 Like

A wonderful example of the power of Open Source. Thanks for link!

Follow the same blog. Would recommend reading it

Have you tried changing the RTCM rate at the base? For me I’m seeing this issue consistently after about 20 minutes when L1 observations are set to 1Hz but not when changing to 5Hz. So far holding fix over an hour.

This is over NTRIP. Not sure if radio link would be OK at 5Hz.

I’d be interested to hear if this makes a difference to you.

at the moment i had brick my mxc connector - it is not perfekt for hard testing ;-).

if i use a ntrip server with 5 hz i had no problems to hold fix.

i did not try to use my own base with 5 hz. maybe more data will give better results.

radio link would not work at me because i can´t use 100% duty cycle. radio is also not perfekt for me because
i need connectons >5km…

if my hardware is working again and we have better weather i will start testing again.
i also have a m8t from csg-shop - i will try to use both and compare.


I am having trouble with getting a fix and I decided to turn to this forum for help…Can anybody help me? I can’t find any consistency in what gets me a fix now. Sometimes it will do like others have said. Go all the way up to AR 999 and then slowly over the next 20 minutes or half hour drop down till it loses its fix and then it’s impossible to get it back. At no time will it start climbing again. Earlier I had great fixes, but now, the last weeks, it’s just been like this or no fix at all. I’m not sure what I’m doing wrong. I’m so excited where Emlid is taking us, but I don’t want to be left behind :slight_smile: struggling with fixes. I turned off NTRIP and did it over my local network. I have tried all the different configurations I could think of. I can post my logs if anybody is interested in taking a look at them. Thanks!


acoording to :slight_smile:

i hope emlid with include this asap and bring back raw correction data soon.

My wish for further reachview: i would like to do some settings in rtk.conf at my own.

Is it possible do share if this ?

1 Like

Are you using Reach as a base also? If so, try setting the message rates for L1 observations to 5Hz on the base tab:

Seems to be working for me, I don’t see the issue now.

Otherwise, I heard that there will be a new release with a fix for RTCM encoding coming out next week…

1 Like