LoRa is not connected Reach M+

Hi all,

I’m using EMLID technologies for years now and I used it in my different jobs. I already check for similar problem but the topics are from 2019.

My problem is that since an update from v2.6 to V26 then V27 , I can not use the input correction anymore from the LoRa.

When I click in Lora, I directly have this footer “LoRa is not connected”.

And this before to click apply.

I tried to reboot my device with LoRa connected, disconnected, check for updates… but nothing changed.

The LoRa is the LoRa provided with the pack when buying reach M+.

Then I had an idea, it was to go in debug mode, and remove the disable option from the CSS of the Apply button to force to use the LoRa even if not connected.


I still have the footer “LoRa not connected” but also the information connected alternatively with waiting.

Of course my wiring is OK, I used the wires from the packages, it is made of 2 JST connectors of 7 pins, but with only 6 wires, (123567) the 4 is missing, and when conencted on S2 of the reach M+ it is the GPIO 0.

Following is the simple report made from the application.

[details="Simple system report"]
```
app version: 27.0-r4
current_network:
  ip: 192.168.10.176
  security: wpa-psk
  ssid: guest
enabled: true
mode: client
base_mode:
  base_coordinates:
    accumulation: 120
    mode: single-and-hold
  output:
    io_type: 'off'
    settings:
      cloud:
        mount_point: ''
      lora:
        air_rate: 9.11
        frequency: 865000
        output_power: 20
      ntripsvr:
        address: ''
        mount_point: ''
        password: '***'
        port: -1
      serial:
        baud_rate: 38400
        device: ttyEXTS0
      tcpcli:
        address: localhost
        port: 9001
      tcpsvr:
        port: 9000
  rtcm3_messages:
    message_1002:
      enabled: true
      frequency: 1
    message_1006:
      enabled: true
      frequency: 0.1
    message_1010:
      enabled: true
      frequency: 1
    message_1097:
      enabled: false
      frequency: 1
    message_1107:
      enabled: false
      frequency: 1
    message_1117:
      enabled: false
      frequency: 1
    message_1127:
      enabled: false
      frequency: 1
bluetooth:
  enabled: false
  pairing:
    discoverable: true
    pin: '***'
camera_trigger:
  duty_cycle: 20
  enabled: false
  period: 2
  reverse_polarity: true
correction_input:
  base_corrections:
    io_type: lora
    settings:
      bluetooth:
        send_position_to_base: false
      cloud:
        mount_point: ''
        send_position_to_base: true
      lora:
        air_rate: 9.11
        frequency: 865000
        output_power: 20
        send_position_to_base: false
      ntripcli:
        address: rtk2go.com
        mount_point: Solothurn
        password: '***'
        port: 2101
        send_position_to_base: false
        username: ''
      serial:
        baud_rate: 115200
        device: ttyEXTS0
        send_position_to_base: false
      tcpcli:
        address: localhost
        port: 10001
        send_position_to_base: true
      tcpsvr:
        port: 10000
        send_position_to_base: true
device:
  privacy_policy_accepted: true
  role: null
  rv3_banner_shown: false
  usage_analysis_accepted: true
logging:
  logs:
    base:
      autostart: false
      format: RTCM3
      started: true
    correction:
      autostart: false
      format: RTCM3
      started: true
    raw:
      autostart: false
      format: UBX
      rinex_options:
        logging_interval: 0
        marker_name: null
        pole_height: null
        satellite_systems:
          beidou: true
          galileo: true
          glonass: true
          gps: true
          qzss: true
          sbas: false
        time_adjustments_enabled: null
      started: false
    solution:
      autostart: false
      format: LLH
      started: true
  settings:
    debug: false
    interval: 24
    overwrite: true
position_output:
  output1:
    io_type: 'off'
    nmea_settings:
      bluetooth:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      serial:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: false
          update_rate: 1
        gst:
          enabled: false
          update_rate: 1
        gsv:
          enabled: false
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: false
          update_rate: 1
        zda:
          enabled: false
          update_rate: 1
      tcpcli:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      tcpsvr:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
    settings:
      bluetooth:
        format: NMEA
      serial:
        baud_rate: 115200
        device: ttyEXTS0
        format: NMEA
      tcpcli:
        address: localhost
        format: ERB
        port: 9000
      tcpsvr:
        format: LLH
        port: 9001
  output2:
    io_type: 'off'
    nmea_settings:
      bluetooth:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      serial:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      tcpcli:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      tcpsvr:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
    settings:
      bluetooth:
        format: NMEA
      serial:
        baud_rate: 115200
        device: ttyEXTS0
        format: NMEA
      tcpcli:
        address: 192.168.0.102
        format: NMEA
        port: 9001
      tcpsvr:
        format: NMEA
        port: 9002
positioning_settings:
  elevation_mask_angle: 15
  glonass_ar_mode: true
  gnss_settings:
    positioning_systems:
      beidou: false
      galileo: true
      glonass: false
      gps: true
      qzss: true
      sbas: true
    update_rate: 5
  gps_ar_mode: continuous
  max_horizontal_acceleration: 1
  max_vertical_acceleration: 1
  positioning_mode: kinematic
  snr_mask: 1
```
[/details]

I hope I gave you enough details to help me found what is the problem, because for the moment it seems to not receive the informartion from my base and so I can not have RTK .

I wish you all a lovely day and hoping that someone could put me in the right direction.

1 Like

Hi @guillaume.rosa,

You’ve taken a huge leap from 2.6 to 27! There should be a lot of new things for you.

Still, the issue doesn’t look like related to the update. I’d rather say it’s an interface bug. Maybe you already saw, but we also have a new Reach View 3 app. Please try to set up the LoRa there. If the issue is deeper, it will confirm this at least.

2 Likes

Hi,
Thanks, I will try to use the app 3, but i’m pretty sure i was using this.

I keep you updated.

Hi @guillaume.rosa,

Did you manage to set up the LoRa radio via ReachView 3?

1 Like

Hi all, I was abroad for work and I got back to this project only today.

I tested with reach 3 app and same as before. I included some pictures on how it is wired for the moment.

Language is french.

Hi @guillaume.rosa,

Do you have another Reach M+/M2 or another LoRa cable to test the radio? It’d help to make sure that the issue is in the radio itself.

Unfortunately no, I do not have any other part.
Should I order a new LoRa just to test it ?

In any case we are ordering a M2 and an RS2 so I could check at this moment when I will receive another bunch of LoRa

@guillaume.rosa,

If it’s not urgent, it’d be nice if you could wait and check the LoRa with the new Reach M2. But you can also send a Full system report to us. Probably it helps to understand the cause of the issue. I suggest you email the FSR to support@emlid.com, as it may include personal info.

Regarding missing wire. The Doc shows 7 wires (see picture below). Emlid might confirm if the fourth wire is needed? Either way, the Doc should be updated with correct picture or add text to avoid confusion


Also, could you share details on how your M+ is powered? spec etc

If wire 4 of S2 is the one identified in this picture, I think that is your problem with it not being identified by the M2

Between the pinout above and If you go to the thread below and go to the 8th post up from the bottom (one above Elena’s reply) you will see why I think this.

By the way, I have bought so many different cables with the connectors on them, I am not sure if I am using the Emlid Stock cable or one of them that I bought.

Hi everyone,

It doesn’t have to affect the LoRa connection, but I’m double-checking this information with our electrical engineers now. I’ll write you back when I get something.

For both Reach M+/M2, you can supply the power through any ports in the pinout scheme, like S1 or C1. The connectors support 4.75 - 5.5V power sources with up to 3A. All ports are JST-GH. You can read more about it in our Power Supply doc. The specifications for Reach M+/M2, you can find on our website.

Thank you. This question was aimed at @guillaume.rosa :wink:

@TB_RTK, sorry. I thought you asked me because it came after your question about the cable where you mentioned us :sweat_smile:.

Hi @guillaume.rosa,

I checked the information about the cable. GPIO_0 wire (4th) is required for LoRa as it’s used to detect the connection. So, it seems this’s the reason why LoRa can’t connect to your Reach M+.

However, this’s quite strange that you receive such cable. Is it correct that you got this 6-wire cable with the Reach M+? Did you buy it through our online store or from our dealers?