Looking for more help getting AUSPOS format correct

I’m getting pre-processing errors on AUSPOS. I am very new to this. My goal is to be able to setup Known Points in remote areas to do simple point surveys using a base/rover situation.

Basic Steps:
-I’ve set my Base Station to the parameters on the EMLID AUSPOS - Online Processing Service How to Guide (Position mode to Static, Rinex [various versions] and AusPos settings).

-I have to change the name of the file to submit to AUSPOS. I change the filename to ‘Emlid.22O’. This fails AUSPOS pre-processing.

-I have converted the file using Emlid Studio. This fails AUSPOS pre-processing.

I am getting a solution on OPUS - but I’d rather be using AUSPOS for our work.

This is the error message from AUSPOS: ERROR (PrePPP-Processing, Please check the Span, Types of Obs (L1 and L2), Quality (L1 and L2), and Format of RINEX file (BASE15DEC22.22O)) from AUSPOS

This is my header data from the RINEX file:
ES dev:627ffa9c-Dev 20221219 080010 UTC PGM / RUN BY / DATE
log: C:\Users\adam.diaz\OneDrive - Gold Road Resources\EmlidCOMMENT
input_format: RINEX, option: -TADJ=0.1 COMMENT
-2363611.9644 4873729.9667 -3356280.4202 APPROX POSITION XYZ
5.0000 0.0000 0.0000 ANTENNA: DELTA H/E/N
2022 12 14 23 59 0.9990000 GPS TIME OF FIRST OBS
2022 12 15 5 56 0.0040000 GPS TIME OF LAST OBS
C1C 0.000 C1P 0.000 C2C 0.000 C2P 0.000 GLONASS COD/PHS/BIS

2022 12 14 23 59 0.9990000 0 8
G 2 21484122.042 1 112899805.167 2 2609.662 42.000
G11 22305501.349 1 117216200.093 3 -2583.740 37.000 22305511.822 8 -2012.879 26.000
G12 21095774.735 1 110859001.007 3 -1007.015 35.000
G18 24128699.327 9 3429.921 19.000
G20 23542489.359 1 123716626.396 4 775.684 33.000
G24 22339808.991 1 117396489.624 2 -3757.435 40.000 22339809.962 1 91477789.120 2 -2927.945 40.000
G25 20527889.430 1 107874796.436 4 644.336 37.000 20527890.857 2 84058247.790 4 502.478 34.000
G29 20868598.699 1 109665225.415 3 387.177 35.000 20868597.658 2 302.068 31.000
2022 12 14 23 59 1.9990000 0 8
G 2 21483625.448 1 112897195.139 2 2610.385 42.000
G11 22305993.035 1 117218783.809 3 -2583.616 37.000 22306003.919 8 -2013.362 26.000
G12 21095966.450 1 110860007.963 3 -1006.556 36.000
G18 24128046.774 9 3425.704 20.000 24128060.803 9 2673.142 31.000
G20 23542341.494 1 123715850.210 4 776.251 33.000
G24 22340523.897 1 117400246.611 3 -3756.624 40.000 22340524.889 1 91480716.626 2 -2927.509 40.000
G25 20527766.687 1 107874151.379 4 645.404 38.000 20527768.380 2 84057745.164 4 503.326 34.000
G29 20868524.832 1 109664837.905 4 387.905 34.000 20868524.155 2 302.226 30.000

Doesn’t AUSPOS have some webpage with the criteria for their processing engine?

Hi @wizprod ,

AUSPOS does have a semi-useful site with upload criteria.

But as a newbie, and with a week’s worth of reading, I can’t seem to make sense of why my RINEX file isn’t being processed.

The checklist:
Before submitting your GPS RINEX file/s, please ensure:

  1. AUSPOS only provides a network solution (relative positioning) using a double-difference strategy. Dual-frequency (L1 and L2) measurements are necessary. I think this means I need to set the base station GNSS settings to Static

  2. Please make sure all RINEX files submitted to the same job contain an overlapping period of more than one hour. Otherwise, submit them individually to different jobs. I’m only submitting one file

  3. DO NOT submit measurements for the current UTC day. Please wait until the next UTC day after 0300 (3 am) UTC time. This allows the RINEX files of reference stations to be downloaded for the current UTC day. I have been recording on one day and submitting 24hrs later

  4. DO NOT submit receiver raw binary files (for example files with extension: M00, T01, T02, DAT, SBF, TPS…). I am only submitting the observation file

  5. ONLY submit RINEX observation “.O” files. DO NOT submit RINEX files with extensions: “N”, “M”, “G”, “L”, “P”, “H”. The observation file that is downloaded from the RS2+ is written as name.22O, I’m not sure if the ## part matters.

  6. RINEX filenames should NOT contain any special characters, symbols or spaces. The file name that is downloaded from the RS2+ is BASE-Emlid1_raw_20221214235825.22O which I rename to BASE.22O simply by renaming it Explorer…not sure if this is corrupting the file

  7. The station name will be read from the first 4 letters of the “MARKER NAME” line in the RINEX header. I’ve set the Marker Name in the RS2+ Settings and can see it in the .22O file

  8. Please make sure the interval (INTEGER only) of measurements is equal to or bigger than ONE second. It is better to have all RINEX files with the same interval. I’ve set this in the settings and have tried to set it in the RINEX convertion tool using Emlid Studio. The readings still come out with a long decimal where the seconds are. Not sure if this is the issue.

  9. DO NOT use special characters for “MARKER NAME” and “MARKER NUMBER” in the RINEX header. ONLY use numbers and/or letters from the modern English Alphabet. Check

  10. After the “END OF HEADER” line in the RINEX header, only observation data should be present (Epoch time and Measurements). Please check before submission. After inspecting the RINEX file in Notepad, I feel this is ok. Although the Sat_IDs? are on each line…I would think this is necessary.

  11. If BOTH C1 and P1 (C2 and P2) code measurements exist in a RINEX v2 file, P1 (P2) is given priority to be processed. Please make sure all GPS satellites contain P1 (P2) measurements. I don’t know how to investigate this

  12. If only C1 (C2) code measurements exists in RINEX v2 file, Please make sure all GPS satellites contain C1 (C2) measurements. I don’t know how to investigate this

  13. For RINEX v3 files, C2S (code measurement) and L2S (phase measurement) from L2 frequency will NOT be accepted. I don’t know how to investigate this

  14. For RINEX v3 files, currently, the accepted measurements from L1 frequency are C1P and L1P; C1W and L1W; C1C and L1C; and C1X and L1X. I don’t know how to investigate this

  15. For RINEX v3 files, currently, the accepted measurements from L2 frequency are C2P and L2P; C2W and L2W; C2C and L2C; C2D and L2D; and C2X and L2X. I don’t know how to investigate this

  16. If RINEX files are Hatanaka compressed, please use the lower case “d” for the filename extension. I’m not using Hatanaka compressed.

Hi Adam,

Can you share the RINEX itself? I want to examine it and try to post-process myself.

You can PM me with it if it’s sensitive data.

BASE-Emlid1_raw_20221213053203_RINEX_2_12.zip (5.4 MB)
BASE-Emlid1_raw_20221214235825_RINEX_3_03.zip (5.8 MB)

Hi @svetlana.nikolenko ,
Here are the two zips from the Emlid.
These aren’t sensitive data. They are just recordings to work out the AUSPOS side of things.

Hi Adam,

I think there is just not enough data for AUSPOS to provide you with the results. The data is quite noisy and SNR is unstable. You may see a lot of small red dashes–cycle slips–during the whole log. They mean interruptions in data reception. It’s ok to have them when a satellite is low above the horizon. But if the sat is almost in zenith and there are cycle slips, it tells us about not that good environmental conditions.

Also, the Signal-to-Noise ratio is quite jumpy.

AUSPOS works with GPS only, so GPS signals should be almost ideal. By these logs, I’d say you’re working with obstructed sky view. Is it so? Can you share pics of your worksite?


Hi Adam,

Other than leaving the Emlid soaking for longer and ensuring a clear sky view, you could also try using the Time Rounding setting in Emlid Studio. Not sure if AUSPOS prefers it, but OPUS does, and I’ve had issues with other software (Applanix POSPac) not liking the native Emlid logs without the time resampling being used.

Just a thought.


  • Mike
1 Like

Thanks @mikeb .
Svetlana was on point. Basically my site location had poor visibility, especially on the horizon. The GPS signals were patchy and inconsistent which made for bad data which I submitted to AUSPOS.

The lesson was pick a better location, and check the data in EmlidStudio for quality.
The Emlid Tutorials were spot on.
AUSPOS doesn’t give a ‘bad data’ error…it just fails at pre-processing.
I also used EmlidStudio to format the RINEX file and to round the seconds.

Thanks for everyone’s help.