Long Range Wireless Bridge Connection Problem with GCS

HI I am running a long range wifi bridge from the Navio2 to a normal network on which my GCS is also a node. The wireless bridge is a pair of Ubiquity Bullet 2HP’s. The end result is that the Navio2 is seen as another node on the LAN as though it is a wired connection, this connection is really robust and gives great range. My one issue is that when I turn the UGV on, it powers up both the Wireless bridge and the Navio2, after a short delay (Time for bridge to establish) I can ping the navio2 and log in using SSH (putty etc), however I cannot connect to the GCS (Mission planner and QGC) without doing a reboot. I figure this must be some sort of mavlink issue? At any stage after the initial connection (once rebooted) if the network drops etc it will automatically reconnect, just never on start up.
I am running The your latest image on a Raspberry PI 4B, and I have implemented the Rover4.0 firmware.

Hi!

Have you tried powering up the adapter or connecting it after Raspberry has booted up? The issues you experience can arise because the adapter is loading too fast.

Please, let us know about the results of that attempt.

Thanks for the reply, the problem does not seem to be with the adapter regardless of the startup sequence; I get a connection to the Navio2 through the wireless bridge via Putty or other terminal (SSH) connections, but even if I have that connection I cannot get a connection through most mavlink type ground stations, until I do a reboot. The bridge remains connected during reboot, and then I can do a mavlink connection with no problems.

Hi @ralphkoch,

Sorry for the delay.

Could you please, specify whether you use TCP or UDP connection and provide me with the photos of your hardware setup?

For me, it looks like a networking issue of the bridge. Do I get it right that you need to reboot the GCS? If yes, then the rebooting should involve network scanning. Maybe the GCS can’t detect the IP address of the Navio2 without an additional network scan because of the bridge. Could you try to conduct the same setup without it?

Looking for your reply.

Hi Thanks for the reply,

The setup is very basic: Navio2 plugs into 5 port switch, Switch goes to Wifi Bridge, other side is almost mirror image, but instead of plain switch the ground station hooks in via wifi to my local router.

What makes me think its not a network issue is that I can log into Navio2 using SSH from the GCS Laptop through any terminal app (Normally Putty) after all the network settles (no reboot or anything). My issue is that even when I know there is a great Network connection between GCS laptop and Navio2 (I test it with iperf and get over 40Mbs) yet I cannot get mission planner or QGC to connect unless I first do a remote reboot of the Navio2?? That’s what made me think it was a protocol issue with the mavlink as I have a great network connection between the GCS laptop and the actual Raspberry Pi / Navio2.

Best Regards

Ralph

Hi,
I believe there is a setting in the network config section of raspberry config which allows to set raspberry only to continue booting sequence once network is established.
In other words currently certain network settings are made during startup on assumption rather than actual network settings, hence communication mismatch.
The change will only take a few more seconds during startup but will ensure correct connectin values are used.

1 Like

@ralphkoch,

Could you, please, try the workaround suggested by @kschoelpple? I think that this approach will enable to register the Raspberry board in your network.

Hi Guys,

Thanks for the suggestion, I tried it and yes it does work, but its not really a permanent solution as occasionally operators will want to use the robot without a full network being up, and waiting for network to boot causes other complications. They may wish to do line of sight remote without having telemetry and network. It still also doesn’t really give a clue as to why mission planner or other mavlink GCS programs cant connect without reboot once a network is up, its not an inability to establish the network, because the pi can communicate through ssh to putty, its just that Mission planner wont connect???

Hi @ralphkoch,

I’m afraid that the issue here could be set in the Wi-Fi bridge and the GCS and not the Navio2 itself. It is hard to say how does GCS treats the network connection via the Wi-Fi bridge, that is why I’m afraid I can’t provide you with a ready-made solution on this.

The only workaround I can suggest for now is to simplify the setup and check whether everything works. Could you please test the Navio2 without the Wi-Fi bridge? If everything works fine, you can start adding the other equipment to the setup so that it will be possible to localize the problem.