Logging via usb, /dev/ttyACM0 no longer detected

Hi Emlid,

I have successfully been able to log position NMEA GPGGA data from my Emlid REACH RS2 device to my laptop or jetson computer using a USB cable and parsing the serial code /dev/ttyACM0 on Ubuntu.

However, the /dev/ttyACM0 serial has stopped appearing on my PC’s. I’ve tried all usb ports and different cables but the problem persists. Do you have any experience with this?

Thanks!

Hi Derek,

Does Reach behave as expected in general? This issue may be related to both Ubuntu and Reach. So, we need to localize it somehow. For example, you can check if Reach outputs its position via TCP. If you have another PC and can check USB output there, it helps too.

Hello Svetlana,

Thank you for your message. Yes other behavior is running just fine. Can still get logging data via TCP ssh. I already tried the usb on two devices and both used to, but no longer detect the ttyacm0. My next guess is to reset the emlid to factory settings, perhaps that will work?

I am trying to reflash using https://docs.emlid.com/reachrs/reach-panel/firmware-reflashing/. However, I am not able to connect the reach in firmware mode, ,likely because, again, the usb is not registering. Can I reflash without usb connection?

Hi Derek,

I hope your Reach is not reflashed yet :smiley:

The reflashing procedure can be done only via a USB connection.

Entering Reflashing mode on Reach RS2 is quite tricky :slightly_smiling_face: You should follow the steps right as shown in the guide about reflashing of Reach RS2.

However, let’s hold it for a while. I’d like to check first if the unit really needs reflashing.

Does the unit charge over USB? Is there a LED indication of charging?

Have you noticed something irregular before the unit stopped appear in the list of connected devices?

Is it possible that you’ve changed the settings of Position output in Reach RS2?

1 Like

Hi Andrew,

When I plug in the charging cable via usb the device lights up (without blinking) for one second, and then does not show any lights. I guess this means it’s not charging?

I can’t say I’ve noticed something irregular… I have played around with position output settings. Don’t think it has anything to do with that.

It seems to me the usb connection is not very stable anymore, is this something fixable, can we replace the usb input in the emlid?

Derek,

Yes, the white LEDs should start blinking. It looks like the unit doesn’t charge.

Let’s switch our conversation to emails since further troubleshooting may require sensitive info from you.

Can you share the Full System report from the unit with me by sending it to support@emlid.com?

To generate a Full System report, you should do the following:

  1. In the ReachView 3 app, go to the Settings
  2. Then open General and find the System Report bar
  3. In the pop-down menu, choose to Generate Full report