Emlid

LinuxPWM_Sysfs:Unable to open file /sys/class/pwm/pwmchip0/pwm0/duty_cycle: No such file or directory


#1

I tried to start arducopter, but I could not start it.

pi@navio:~ $ sudo ./ardupilot/build/navio2/bin/arducopter -A 192.168.2.108:14550
Raspberry Pi 3 Model B Rev 1.2. (intern: 2)
LinuxPWM_Sysfs:Unable to open file /sys/class/pwm/pwmchip0/pwm0/duty_cycle: No such file or directory

pi@navio:~ $ lsb_release -a
No LSB modules are available.
Distributor ID: Raspbian
Description: Raspbian GNU/Linux 9.6 (stretch)
Release: 9.6
Codename: stretch

pi@navio:~ $ uname -a
Linux navio 4.4.36-v7+ #933 SMP Fri Dec 2 22:03:01 GMT 2016 armv7l GNU/Linux

pi@navio:~ $ lsmod
Module Size Used by
binfmt_misc 6388 1
evdev 11396 1
brcmfmac 186403 0
brcmutil 5661 1 brcmfmac
cfg80211 428431 1 brcmfmac
rfkill 16037 4 cfg80211
bcm2835_gpiomem 3040 0
bcm2835_wdt 3225 0
i2c_bcm2708 4834 0
spi_bcm2835aux 4427 0
spi_bcm2835 6678 0
uio_pdrv_genirq 3164 0
uio 8000 1 uio_pdrv_genirq
i2c_dev 5859 0
ip_tables 11445 0
x_tables 13165 1 ip_tables
ipv6 347594 28

Please teach me.


#2

Please tell me how to solve.


(Tatiana Andreeva) #4

Hi @kassy3333,

Could you please run sudo emlidtool ardupilot and post the screenshot here?


#5


(Tatiana Andreeva) #6

@kassy3333,

May I ask you to reflash Navio2 with the last image?


#7

I am using the latest image downloaded from the homepage.screenshot01


#8

Depending on various circumstances, I will refresh to 11/26.
After that, should I configure Raspberry Pi and build ArduPilot according to “Navio 2 docs”?


#9

I refreshed.


#10

And I ran “sudo emlidtool ardupilot”
I ran “sudo emlidtool rcio update” to update RCIO Firmware, but I could not update it.


(Tatiana Andreeva) #12

@kassy3333,

Please run sudo emlidtool rcio update -f without rebooting the RPi after that.

Then try sudo modprobe -r rcio_spi && sudo modprobe rcio_spi and post the whole output of dmesg | grep rcio after that.


#13


#14

“sudo apt-get update && sudo apt-get dist-upgrade” was executed.
After that I could do it by running “sudo emlidtool ardupilot”.


#16

Arducopter started successfully!!
Thank you.