Letting battery die caused nothing but issues

About a week ago, I was doing some survey, and after not charging the RS+ I was using for the base, it died. Not a big deal I thought, since I was already finished, and didn’t need to do more survey for another week or so.

But when I tried to charge it back up, it wouldn’t take a charge at all. I tried about 5 different cables and chargers (Car charger, Laptop, DJI charger, wall charger etc etc). NO lights at all. Eventually I had to leave and left it plugged into my laptop. When I came back after 3 hours, the charge light was on. Not blinking. But on.

I thought this meant it had finally charged up. Turns out I was wrong. As soon as I unplugged it, the light went off, and it would not power on at all. (no lights whatsoever when hitting the power button).

After leaving it plugged in overnight, I tried the power button again. This time it would start booting. The 3 LED’s would power on and start ‘loading’, but it would always turn off again after a few seconds of loading. And it would not do anything if it was not plugged in.

I read something on the forums about it trying to connect to WIFI and needing to time-sync. So I drove it away from the office and plugged it into the car charger. This time it actually booted up to the point where reachview could connect to it.

Even after being plugged in for over 24 hours. It said “State of charge: 0.00%”

While I was looking through the settings, the charge slowly started going up. It was about 10-15% by the time I brought it back to the office, and does seem like it held a charge, since I left it on when I walked inside.

I’m currently updating it from 2.11.0 to 2.18.0, but man has this been a giant pain in the butt. Especially since it meant the survey I wanted to do yesterday had to be done by a 3rd party.

Uh yeah, not good. I’ve seen posts about this, and I dread the day I run into this problem.

Doesn’t seem there is any feedback why exactly this happens?

Also, rechargeable batteries prior to these kind in the RS years ago, you used to have to charge full, then deplete fully to avoid the memory effect and less use time if not.

But these new kind of batteries I am finding to just keep them charging as much as possible before they get all the way down. i.e. when not in use, I keep them plugged in at all times.

Hi Grant,

This is not how Reach RS+ should behave when charging.

We will replace this device for you. I believe you are already in touch with our support via email.

Sorry for the inconvenience.


Thanks Dmitriy, yes they have been in contact. Thanks for the quick response from everyone!


This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.