Latest Raspbian image does not have SSH enabled


I downloaded and burned the image I downloaded from this link : Download emlid-raspbian-20170323 SD card image, (md5)

I then started the RPI3, but am not able to do SSH since the SSH is not UP. I cannot use the monitor since my HDMI port in RPI3 is damaged. So, I need the image with the SSH server up. I have requested the support on this.

without monitor, it is hard to login and install/enable SSH. any thoughts?


Hello there!

SSH is enabled by default. I suggest looking into your ‘/boot/wpa_supplicant.conf’ in case you’re trying to connect over Wi-Fi. You can also try creating an empty file /boot/ssh. Just to be sure. If your HDMI port is damaged, you might experience other problems. I suggest adding hdmi_edid_file=1 to /boot/config.txt

Thanks for your response. I have been using this RPI3 before (with older version of image) and have a static IPaddress issued to this mac in my router. So, I always ping to it “ping” and the ping works. so, it is connected to wifi. So, now, after you said, I did create a file in the SD root folder.
note: when I use the SD in my windows computer, I see the name as root and the many files and just 1 folder called overlays. all are .bin files. (this is an image and the OS boots off this. I see). just wanted to make sure.

so, when I connect using putty as always to the above IPaddress, it immediately says “server unexpectedly closed network connection”.

I have a centOS 7 always up, I tried from there from command prompt… it gets the error “connection closed by”…

so, still wondering what might be the issue. before this, I had the old image and used to do ssh and start ardupilot quad and so on and test my navio2.

Could you please try connecting like this ssh pi@navio.local? The same applies to Putty. There’s a very little possibility your MAC-address has changed with miscellaneous fixes for internal Wi-Fi. Even though, I doubt it. You can also try connecting over Ethernet. You can try checking out other like this IPs or in router settings in DHCP-leases tab.

Well, the IP address of RPI3 is and it shows in my router as connected. the ping works.

now, from my CentOS / Linux machine, I could do ssh pi@navio.local , but, just by reading this I am saying “navio.local” is just a hostname and that in turn points to

well, if I connect my RPI3 via Ethernet cable directly to my windows laptop / CentOS machine, I would have to determine its IP address and then ping it and then connect to it. need to update some parameters in /etc/network I guess. have to google and do this. anyways, let me know if you can simulate at your end provide me any info…
thanks in advance

Unfortunately, I wasn’t able to reproduce on a freshly downloaded and burnt SD-card? Consider reflashing? (I guess you’d already done it, though)

I did it. I have the image on 2 SD cards now. I used the etcher and it also verified that it had successfully burnt. There is something with the new image that is preventing me from logging in via SSH. I see creating the /boot/ssh empty file signals to enable it. I understood your point. but, did not work. let me download again, burn the image again and try it. really strange. regards

What kind of error you see when trying to connect? Is it possibly you copied you added old Raspberry Pi’s credentials to `/.ssh/known_hosts on your PC (to be completely fair, I do not know where exactly it’s stored at on Windows boxes)? It might prevent you from logging in.

Good News: it worked !!!

Sorry my mistake. I really apologize.
I remember, last year, I had setup SSH port-forwarding on my netgear router and had the port as 33 and mapped to internal port of 22. so, previously, the ssh to port 33 would have worked like a champ. now, since I deleted that port forwarding on my router, I can now do ssh to RPI3. This was the mistake. made by me.

I went to my router, deleted all assigned ipaddress to the mac. applied it.

So boss, please close this ticket. Again, I apologize. guess, I am getting old. :slight_smile:

Nothing to be sorry about! This things are so easy to be forgotten. It’s awesome you figured it out by yourself.