Land mode, landing gear retract is reversed?

Hi

My hexacopter with ArduCopter 4.0.3, has servo controlled landing gear.

I’ve configured a Servo PWM and RC Aux switch to 29.
This works fine for manual retract and deploy.

But when I boot the drone, with gear deployed, Mission Planner will say: Landing Gear: Retract, but nothing happens. Then when I enter Land Mode the gear will retract from deployed state.

So it seems something is reversed?
How do I disable Gear interaction when using Land Mode?

Hi,
If using Mission Planner just go into advanced settings and search for channel 29 (RC29). Then change to reverse. Or you can go directly into the settings file (using a text editor like “Notepad” on Windows or “Kate” in some Linux distros) and look for RC29. There will be a line saying " RC29_REVERSED,0" change the 0 to a 1 and save file. – Do not do this whilst a groundstation is running ( APM Planner, QGroundControl, Mission Planner).
Also in those settings you can disable landing gear control, both using a groundstation software or directly in the settings file.
See also https://ardupilot.org/copter/docs/common-landing-gear.html#common-landing-gear
and perhaps archieved version https://ardupilot.org/copter/docs/landing-gear.html

Hi

When searching in Mission Planner I can’t find any RC29, only RC1 - RC16

[edit]
I tried reversing RC6 which is the channel I’ve configured for landing gear, but this didn’t have any effect, even after a reboot.

Which settings file do you mean I should open?

I think my version of ArduCopter is to old. I don’t have the LGR_OPTIONS setting.

In Mission Planner under the Config Screen --> Extended Tuning page select a channel you have available on your RC receiver and assign this as “Landing Gear”. Then you will have also access to a channel number which you can reverse.

  • Update: I’m running same version Arducopter as you do. But checked in QGroundControl and found in there you can easily assign any channel from 6 to 16 as landing gear. - This is helpful if you don’t have a lower channel number available.
  • Using QGroundControl in Parameters it has a search field at the top. Just enter LGR and it will show all relevant settings in regards to landing gear.

I’ve upgraded to latest ArduCopter which has
LGR_OPTIONS: Landing gear auto retract/deploy options

And set both auto retract and deploy to zero.

Haven’t been to the field yet and tested.

I also believe there has been an issue with the landing gear function in Arducopter 4.0.3. Hopefully this is rectified in later version.

Hi Jacob and Karl.

@Dacobi, please keep us posted about your progress.

@kschoelpple, thanks a lot for your help!

Hi

I’m waiting for access to a car, then I can go to the field and test if the new settings has done the trick.

Hi Jacob,

Have you got a chance to test the new firmware?