Emlid

Community Forum

Kernel/rcio/status/crc does not exist


(Ilya Yevgeniyevich Semenov) #1

I had this issue when trying to upgrade from Arducopter 3.4.6 on Jessie. So I backed up the image and flashed a brand new stretch image emlid-raspbian-20180525.

All I have done since then is set up internet access with:
sudo nano /boot/wpa_supplicant.conf
and then do:
sudo raspi-config --expand-rootfs
and
sudo apt-get update && sudo apt-get dist-upgrade

rebooting after these steps

Then, I ran:
sudo emlidtool ardupilot
Got the RCIO upgrade prompt, hit yes, then rebooted.

Now, when I try to run sudo emlidtool ardupilot I get this error:
"No such file or directory: ‘/sys/kernel/rcio/status/crc’

sudo emlidtool rcio restart results in the same
sudo emlidtool rcio check or update gives
“Please verify that rcio_spi is loaded and /sys/kernel/rcio/status/crc exists”

I am not sure what to do, cannot find same issue anywhere else. When I browse directories kernel/rcio doesn’t even exist.


(Ilya Yevgeniyevich Semenov) #3

I was taking a look at: RCIO fails to load

And found that I do indeed have /sys/class/pwm/pwmchip0 there. I am still not sure how to fix this though.


(Tatiana Andreeva) #4

Hi @ilya_semenov,

Please share the output of following commands:

  • dmesg | grep rcio
  • lsmod

(Ilya Yevgeniyevich Semenov) #6

Hello all,

Sorry about the late response. I never solved this particular issue, I do have the image of this configuration if you would like to investigate the deeper issue.

What I ended up doing was flashing another fresh raspian image, and NOT updating and upgrading after the initial set up. This resulted in no RCIO upgrade prompt upon entering emlidtool, the issue I posted about did not appear as a result.

I do think there is some conflict within the upgrade-update procedure and its interaction with the new emlidtool and RCIO functionality. But I was able to bypass the issue.


(Tatiana Andreeva) #8

Hi @ilya_semenov,

Glad to hear that you’ve found the way how to get rid of the issue.
Thanks for sharing it with us!


(Dmitriy Ershov) #10