Jessie don't work

Please Emlid devs can’t you just tell us what’s that little hidden hack to make your hardware work with raspbian ?

I have never and will never use that ***** 2014 gcc 4.6 rt image. No thank you. We are soon in 2016.

I paid my board. can’t you just tell us that little piece of ascii character in that little hidden file which enable gps and servo operation when using raspbian ?

Seriously I want my pi2 jessie distro gcc 5.0, 4.1 prempt kernel which is far better on cyclictest than that
3.18-rt with gcc 4.6 horrible arm7tdmi thing
plus I can do c++11 vfpv4 things (and others).
Please lower your landing gear and land you are not linux developers, if you have problems to implement driver I would be happy to help.
One year outdated documentation oh god…
I don’t blame you when I see how stupid the rtos on stm32 alternative is implemented (crazy messaging layer on useless and the worst of all rtos)

But gps and servo just doesn’t work because of a **** hidden thing, I havn’t been able to find. i2c set to 1MHz… fixed 900MHz cpu cycles.

I am really disappointed by all the time wasted. Seriously it is few ICs connected by non proprietary spi and i2c, to make it fails like this I would have had to want it.

Ascii characters and name of the file please. What have you done to the arm tdmi **** image to work please.

I am running standard Raspbian Jessie, no problems so far. RT patch on standard Jessie is unstable, so I am just on standard for now.

Why gps fix take one second with out of the box 2014 wheezy RT img.

And with the 21 november 2015 raspbian pi2 image I cannot get any fix whatever time I wait… Servos down also.

I don’t want any RT thing. I am very happy with 4.1 rpi2 latency believe me. It is not really the case with 2 years old gcc 4.6 things.

Help Me Please !!!

Yes, no problem. It can even output digital RRC filtered H265 video on gpio4.
I prefer to hear nothing than bullshit. You’ve done a particular thing to make it work on your custom image and I want to know what.

Please read my post, I am on standard. Servos and GPS going for me, so not sure what is wrong with your setup.

Right now I am on your custom rpi2-rt-20150401 image gps working.
Just in case it can help I also see this

pi@navio-rpi ~/repos/Navio/C++/Examples/PPM-decoder $ sudo ./PPM
2015-11-26 04:15:07 initMboxBlock: init mbox zaps failed
2015-11-26 04:15:07 gpioTick: pigpio uninitialised, call gpioInitialise()
2015-11-26 04:15:07 gpioSetAlertFunc: pigpio uninitialised, call gpioInitialise()

Other things work great no noise.

I will try again with my Jessie image.

Just to be clear, I am not working for Emlid.

I installed my own Jessie and I am testing latest ArduCopter…

Ok sorry.


Hello there!

As we’ve already said, we’re working on the new image. Jessie is quite different from Wheezy. Namely, the most drastic change is systemd. We need to work out a lot of petty details to make the image backward-compatible. Raspbian Jessie also has GUI enabled by default and new glibc version. It takes time to deliver the smoothest upgrade possible.

If you use Raspberry Pi 2, then you can go forward and follow our instructions to make the newer kernel (the mechanics behind the process stay the same).

Bear in mind that, it seems that USB FIQ driver hasn’t been fixed in mainline kernel yet, though. So you need to disable it in /boot/cmdline.txt.

Newer compilers are indeed great but we need to make sure that they don’t break anything. That’s why we need a lot of time to test. Anyway, you can use newer compilers and newer kernels as well on the older distributions. It seems these are you main concerns now. Please, keep calm. Everything’s going to work out eventually.

1 Like

Thank you problem solved this night by myself. the thing to change was 3 character long.
In fact it was just what I was saying a little hidden magic things.
Can’t just notice a relevant/matching thing in the above post. usb, glibc, systemd, backward thing… GUI no GUI ?? LoL…
am talking about broken gpio in and gps. What a bunch of bullshit. It dont need a Xserver it’s an autopilot not a playstation.
Whatever for Arm11 image no thank you even with gcc 7.0 and the problem was solved so now your hardware work just like a charm. Great job.

To raise the discution level a little if you want to break something with a new compiler make a tarball of it, burn that on a cd and throw. You can even test innovant throwing methods.

Btw keep up the good work the hardware is near perfect and that 5$ pixhawk chip sold 200 is a plain shit full of jitter in comparison. And thanks for the Tcxo on the GPS, that thing is a beast.


Please mind your language. If you don’t understand what the talk is about don’t call it bullshit.
Insults to other community members will not be tolerated and result in access restriction to the community.


There is a key point to make navio works and it is not in the docs and it makes me waste my time uploading/testing 4gb images on 3mb/s sdcard.
But if you want to talk about gui,usb, glibc, wheezie not wheezie… things it’s fine just let me one second to leave before.