Issues with importing a DXF file

I have been trying to import a dxf file with no luck. Tried converting a kml to dxf and shape in Qgis, both failed to import. Also tried export from Agtek Gradeworks as dxf also failed. Be nice if it gave a reason.

Hi Joe,

Could you send me the KML, converted DXF, and SHP files from QGIS and Agtek so I can replicate the issue?

If the files are sensitive, you can email them to and let us know.

1 Like

Hi Ruth, I sent those out last week, let me know if you didn’t get them.
Thanks for taking a look.

Hi Joe,

I’ve checked the files that you sent me via email, and here’s what I’ve found.

  1. The dxf file has a surface in it, so importing it into Emlid Flow may have caused some issues. Emlid Flow only accepts points and lines for now.
  2. The KML file is in geographic CRS. The prj file associated with the shapefile is configured to NAD83(2011) / Texas South Central (ftUS) - EPSG:6588. So there may have been some issues in the background reprojecting the CRS and converting the KML file to shp.

I was able to import the file in Emlid Flow by first reprojecting the KML’s CRS to EPSG 6588 and then exporting the file to dxf. Please note that the CRS of the project in Emlid Flow was set to NAD83(2011) / Texas South Central (ftUS).

I sent the reformatted dxf file to you via email.


Thanks Ruth. I’ll make sure I leave the surface out next time.