Issues with Getting a Solid Fix... Settings issue?

I have been messing with my emlid units for quite some time now and I still cant seem to get a constant fix. It seems it skips between fix and float quickly and wont ever provide a good fix for me to actually start surveying.

My site doesn’t seem to be ideal for the Reach, but is there any settings or anything that I am overlooking? I have a base and rover and am connected using LoRa. I have taken the unit to a wide open field and am able to get a good fix every time… How can I work around this?

I am trying to use on a property with lots of tree cover and canopy. Photos are attached of my site and settings… Any suggestions? Should I change my settings? Thanks in advance!!

From your settings and photos, I would have the following recommendations:

  • enable all possible systems on both rover and base
  • set gps+GLO L1 messages for Lora to 1 hz on the base
  • up your data-rate til max, both rover and base
  • avoid getting near/under trees as much as possible
  • if possible, post process your data.
  • elevate your base and rover more, so they see more of the sky.

Welllll… that looks to be your real problem.

Seems you would need the new multi-frequency RS2 (1 via NTRIP CORS) or (2) via LoRa. But then you have to wait until available and delivery. : /

You may have to locally rent a good multi-freq GNSS or total station in the meantime if project needs to get done. And then you have to be familiar with the systems. : /

Personally, projects with tree cover like this, the single freq. L1 Reach RS/RS+ is worthless for FIXED cm accurate work. You would have to get the base and rover above the trees which is a joke.

You may need to send over more screenshots of your satellite constellations used and their RTCM3 messages and freq.

One thing you can try, but you’ll defeat the purpose of using as many sats as possible which is ideal, is try setting your Elevation mask Angle in RTK settings from default 15 deg to to a higher angle or narrower cone such as 30 deg max in steps. Also the SNR Mask. Doing this reduces or clips the amount of sats to use. But something you can try to see if it “may” help get a fix within that area of tall trees, home.

I would start with the higher max as @timd1971 suggested, but maybe not that big of an increase. Try 20deg with only GPS and see what you get. If not then add GLONASS. If not then take off GLONASS and add Galileo and so on. This is one of the first exercises I go through when I get to a site and my last site’s settings are not working.

1 Like

try this very useful app. Use the AR View mode and you can see what sats are available at the time and location you are in using the settings. You can adjust the elevation angle mask also. Make sure not to select the multi-freq sats or you’ll get a false representaiton, stay with the L1 sats when using Reach/RS/RS+.

Apple iOS:


I think you are in MI correct? You need to be enabling GPS, GLONASS (or toggle between BEIDOU), GALILEO, and SBAS (these add to the GPS). Don’t over use the RTCM messages, just minimum and add slightly until fast fix.

Is that a KNOWN SURVEYED POINT base is set on? if so, then you enter your 2m antenna height. If it’s just an AVERAGED SINGLE, then saved as manual, then antenna height must be 0 (zero).

Hi @tanna.j,

Reach RS+ require a clear sky view 30 degrees above the horizon to provide centimeter-level accuracy. Try to avoid trees, buildings, and all electronics nearby. Follow these base placement recommendations to improve satellite signal perception.

We also can look into your logs to check why you have a hard time getting the fix.

Could you please send us the following:

  1. Raw data log for each base and rover. Here’s the guide on how to download it.

  2. Simple system report for each unit. You can find it in the “Settings” tab of the ReacView app.


This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.