Issue with battery on Reach RS

We have a similar problem with one of our Reach units where even if we leave it charging overnight the power doesn’t seem to increase beyond 50% when unplugged and then drains very quickly. Normally we could work around this by carrying a portable cell phone charger into the field but yesterday after charging all night, when we went to turn it on we got the solid orange and blue LEDs indicating an internal error, and the unit would only turn on if it was plugged into an external power source. After leaving plugged in for a couple hours the unit recovered and became functional but now it seems to have nearly no battery life whatsoever where it doesn’t seem to hold a charge for more than 30min without external power.
When I generated the detailed system report in the battery status report it said:
● battery.service
Loaded: not-found (Reason: No such file or directory)
Active: inactive (dead)

The unit has ReachView version: v2.15.3 Dev

In the Reach set up log there were some errors:

And throughout the file info about the battery like this one:

Is this a software problem where I should reflash the unit or indicate of potentially a hardware failure? I can upload the full logs also if that’s helpful.

Thank you,


Hi @arsl,

Can I ask you to share full system report and reflash your device after that, please?

Let me know about the result.


We haven’t been able to flash the unit yet (v 2.14) (using Mac OS) because it doesn’t seem to be recognized by the utility.

The unit initially turns on with solid orange and blue LED, then it goes to solid orange and then solid orange and green but it doesn’t get past the time sync. It doesn’t make a wifi hotspot and doesn’t try to connect to any known hotspots.

We’ll try reflashing from a windows computer.

Hi @arsl,

Did you try to reflash with Windows?


Yes, we’ve tried a couple different windows computers but it is not working. We get the two problems in the screen captures below.

Initially this one:

And then this one.


The LEDs are solid orange and solid green. The unit does not try to connect to, nor create its own network.

Just now after having posted those errors I tried it one more time, not doing anything different and this time it worked!

Reach view has started and it has now been able to both make its network as well as connect to a wifi network.


This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.