iPhone Hotspot Connections

I have been having issues connecting my RS2 to my iPhone 13’s hotspot. It worked fine for a couple of weeks, but it stopped connecting. I can tell the phone recognizes the RS2 for a brief moment, but the connection fails. It looks like the last post about this is almost a year old, and I would like to know if anyone has had luck since last June.

I have reviewed and watched the guides and repeated the steps enough I could do them in a dark room. The RS2 is new and on the latest firmware. I tried resetting the network setting on my phone. I can probably just use the Bluetooth option, but it seems a new product should keep doing what it should and did. Any advice is welcome. Thanks.

Hi Curt,

Welcome to our forum!

Just to make sure: is the Maximize compatibility option still enabled on the Personal hotspot page of your iPhone?

Are there any difficulties with connecting this RS2 to other Wi-Fi networks? For example, to the Wi-Fi at home or office? It’d be useful to understand whether there are issues with connecting to the internet with every access point or if it’s only with the iPhone’s hotspot.


Hi Liudmila,

Yes, the Maximize Compatibility option is on. No, I am not having any other issues connecting to Wi-Fi networks. I spent some time trying to get it to connect to an app on my phone called Global Mapper Mobile, which took several attempts and was mostly successful. I cannot deny that the problem could be with the phone, but it worked flawlessly for a time. As noted, I reset the network settings on the phone in hopes of clearing the issue. I can attempt to connect to another phone’s hotspot, but I need to find someone with hotspot on their data plan.

I was able to get back on my phone’s hotspot. This is embarrassing, but I hadn’t done a hard restart of the phone. I did that and also renamed the network/hotspot on my phone to my initials to be sure it was unique, and the RS2 recognized it. Chances are it was just the hard restart that did it. I can’t believe I did not think of that before.

1 Like

Hi Curt,

Ah, that’s good news! I wouldn’t think about this too, but it’s great that you figure this out.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.