IOS and reach

Ok I tried the personal hotspot with my iphone and reach module. It does not connect that I can see any where.
After this the reach module shows up in fing on my home network as iphone 5??? I use iphone ipad for my work so not interested in getting android at this time.

I guess its time to get rid of the reach modules as no help with the above and no response as to when the loRa radios will be available asked in a post the other day,seemed like these were going to be the radio’s of choice???/. I have 4 of these and they are not much good when you cannot use them more than 50 feet apart.
And yes I am getting frustrated over this as the reach seems like it could be a good system to use. I realize you can PPK but that is no good for immediate results and is only useful at times for me.


You entered the hotspot info incorrectly on your reach. Please see:

I had a ton of issues with reach but it never ever identified itself as IPhone5. :joy:
Where are you running fing ? Does fing find 2 IPhone5 devices? Why do you suspect that one of those is a reach device ?
Reach identifies itself as “Murata” inside fing.

Make sure your IPhone5 is using WPA2 encryption, I had issues with WPA and WEP routers.

As far as I know it is correct. I did get it connected once to my hotspot but have not been able to again. On another post it said sometimes connecting an other device first would sometimes work tried that and phone did say that I had to devices connected. I was able to use one connected device but could not find the reach module, have been unable to redo either scenario again.

I have fing on my phone and use it lots. The reach shows up as iphone 5 after I try connecting it to my iphone 5 personal hotspot this is the second time this has happened. I know this because it eventually connects to my home wifi and it shows up in fing as Mobile iphone5 but when i connect reachview to that port it is my rover reach.


The first issue is because there is a bug in Reach:

in /etc/wpa_supplicant.conf file the line ap_scan=1 is missing.
Add that line and multiple hotspots will start to work.

Emlid knows this bug, but they did not have time to fix it yet. You have to fix it yourself.

Sorry but as far as I know you can not use fing on a device to detect the clients on that very same device. In other words: you can use fing on your IPhone to detect the IP addresses of devices connected to your home router, but not of devices connected to your IPhone.
So please retry it by deleting all connections from your reach, and inserting only the information of your home (WPA2 encrypted) router. Reboot reach, and connect IPhone to the home router (do NOT use hotspot from IPhone). Now use fing on the IPhone to detect the address of the Murata device (reach). Then you should be able to access reach from your IPhone or home computer.
Configure the home router so that communication between WLAN devices is allowed!!

1 Like

That is ok I can do that but in the field my home router does not reach so need to use my iphone as a hotspot so i can get corrections to the rover.


First use the configuration I described to configure your system.
You can connect all 4 of your devices simultaneously to your router and configure all them at once.

After that either delete the router information from all reach devices and replace it with your IPhone, so that each reach only has a single host information.


add ap_scan=1 to /etc/wpa_suplicant.conf on all reach devices


complain your lungs out until emlid fixes that bug, and then it will start to work as advertised.

BUT: do not hold your breath … emlid people are very busy … :slight_smile:

Thank you Lucas
I do not know where to or how to do this [quote=“Amilcar_Lucas, post:6, topic:6539”]
add ap_scan=1 to /etc/wpa_suplicant.conf on all reach devices

Thanks for helping anyways
This is a pretty basic thing and I am sure there are lots of iphone or ipad users wanting this.
Unfortunately for Emlid team they are not the only ones who are busy but if they wish to remain busy they need to address these things in a timely manner or lose customers.

My rant for the day.

@Amilcar_Lucas We have never said that, please do not speak on our behalf. Adding ap_scan=1 will have no effect as it is already the default setting.

@Jim There is no need to insert any commands in wpa_supplicant. Reach already works with iPhone. We have just tested it with an Iphone hotspot. Maybe the name of your hotspot has changed?

It is very strange that Fing shows you Reach as Iphone5, this is most likely an issue with Fing. Reach simply does not have “Iphone 5” text nowhere on the device :slight_smile: Do you have a screenshot of that happening?

What I have noticed is that when iPhone is in hotspot mode it does not resolve local hostnames, so “reach.local” will not work in this mode. Fing is not able to perform scan on hostpot mode either. For me, the “HE.NET Network Tools” was able to perform the scan in hostpot. Can you give it a shot? (I only tried on Andorid yet) After you resolve the IP address with the app, you will be able to access ReachView.

LoRa radio is embedded in Reach RS, we have never advertised LoRa for Reach. There are answers on this forum for precisely this question. In short, there are some technical challenges to make it work. Currently there is no eta. 3dr/rfd900 radios are a commonly used option and what we recommend in our docs.

@igor.vereninov without ap_scan=1 both my reach units only see the first declared hotspot on the wpa_supplicant.conf file, all the others are ignored.
As far as I remenber someone from Emlid told me to add that line… Am I wrong ? Do you speak on behaf of the entire staff ?

I’m trying to help people here.

@Amilcar_Lucas Maybe something else is modified on your reach? My reach is connecting fine to multiple networks without any mods on 2.6.0

OK, I’ll give it a try one of these days. Thanks.

In this thread it sounded as though you where looking at the lora radios I have used Rf900 before but used them for telemetry now so I guess I will get a couple more of them:

The bottom Mobile is the reach on y home net work. I think your right could be fing’s problem last time I deleted fing and reloaded and it showed up as a murata again.

I will try HE.NET but when I connect my reach to my phone hotspot it says its changing but my menu at top of my phone never turns blue and should also say 1 device connected and it doesn’t. Several days ago I did get it to work for awhile but not able to since. Hopefully I can get this to work as I like your modules.

Thanks for the reply.

Hello All
So I tried to use my iphone as a hotspot again no luck. I must be doing something wrong but have no clue what. I tried the blow and got no where with it. My other devices connect to my hotspot.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.