Integration with 3dr v2 radios

I was able to get two 3dr radios integrated with the reach modules successfully. And important side note for anyone else that tries this: the provided 6 pin cables do not swap the rx/tx lines between two ends (the cables are wired straight through), so you’ll need to swap the two pins for rx/tx to get the UARTs communicating directly if you use this harness. Another note, more for emlid, one of the cables was wired opposite to the same cable in the 2nd box, so perhaps there may be some quality control issues on wiring harnesses to check into.

To configure, I used io port ttyMFD2 and a baud of 57600 (as discussed in the docs). I’m able to see the base sats appear in the rover status bar graphs (as grey bars), so I know things are working.

However, if the two radios are wired to the reach’s before power up, both of the reach devices fail to boot properly. They get stuck with both blue and red leds being on solid (this may be “white”, I’m not exactly sure) and the reachview app never starts. I am also unable to ssh into them while they are in this mode, so perhaps they are hanging somewhere before network config. If I unplug the 3dr radios from the UART connection, boot the reach devices, then plug in the 3dr radios, everything runs fine. Hopefully you can reproduce this on your end.

1 Like


These are good very good points. The 6-pin cable was intended for Pixhawk, so it does not have tx/rx crossed. If you want to connect a radio, then you need to cross them.

Can you also PM me a picture of the miswired cable? I will address this QC issue.

The issues that you have described are most likely related to power. Do you power both the radio and Reach from the USB? If you provide 5V through the DF13 connector is it the same?

1 Like

I am powering the Reach via USB, and then using the UART to power the radio with 5V. So the reach and the radio both get 5V at the same time, when the USB for the reach is powered. I am not powering the radio separately with USB.

As for the miswired cable, I already swapped the pins, so it won’t be much help for you! The ordering of one of the connectors was just backwards (when compared to the other cable).

USB on your PC to which you connect Reach with radio might not provide enough power for both and Reach is not able to boot as a result.

The reach modules with 3dr telemetrie connected seem to boot just fine on a 1A output. Or at least I can acces them with the reach app.

I`ve also tried to power them with a lab power supply with the same result. Total current draw is just under 0.75A total for both units which should be fine for a standart USB connector.

If I provide 5V via an external lipo how can I access the reach app view in my smarthphone or tablet?

Via Wi-Fi, as usual.

Reach has built-in Wi-Fi. In the field you will connect with your smartphone to Reach wi-fi access point and use browser to access ReachView.

1 Like