Installing MAVProxy on Edison Reach Base Station?

Has anyone succeeded in installing MAVProxy on the edison in a reach RTK module?

I tried logging in via ssh, and then

  • git clone mavproxy repo
  • sudo python setup.py install

but then I ran into this:

ERROR: /bin/sh: xslt-config: command not found

** make sure the development packages of libxml2 and libxslt are installed **

So I tried installing libxslt like so:

root@ReachBase[~/MAVProxy]# opkg install libxslt
Unknown package 'libxslt'.
Collected errors:
 * opkg_install_cmd: Cannot install package libxslt.

Any ideas? (I also tried libxslt-dev)

I’m guessing here, but you might need to add another repository to your /etc/opkg/feeds.conf file; one that has the development packages.

I was guessing that too, but I couldn’t find one. Do you know of any?

I can’t find any source repos or source packages for opkg. Maybe you just have to find the source for those libs, e.g.:
http://xmlsoft.org/downloads.html

I tried that too, but my yocto/edison knowledge is too limited. On other Linuxes it is a matter of make and make install. But that didn’t work on yocto. :\

Maybe there is a cross-compiling guide for edison and with that you could compile in a more familiar way on your own computer.

Well, building these libraries from source is not that hard. Most of them are autotools based and all of them provide instructions. I will add libxslt to the image sometime in the future, meanwhile you can use this:
libxslt.zip (1.6 MB)

2 Likes

Yes! It works. In the end I discovered I didn’t need the libs.
pip install lxml pymavlink did the trick.

I now have Mavproxy booting automatically on the edison. The edison is connected to the rover via the radio modem, injects it’s dgps and broadcasts the mavlink on it’s hotspot. Setting up my base station has never been so convenient!

3 Likes