Installing 4 lidar sensors to Navio2

Hello,

We are attempting to connect 4 UART-based rangefinders (proximity sensors) to ArduPilot running on a Raspberry Pi 4 with Navio2. However, when we try to start ArduPilot on our setup with systemctl, it fails. Starting ArduPilot manually returns an error. Below is the command we’ve been using to invoke ArduPilot:

/usr/bin/arducopter -A udp:127.0.0.1:14550 -C tcp:0.0.0.0:5760 -C /dev/ttyAMA0 -D /dev/ttyUSB2 -E /dev/ttyUSB3 -F /dev/ttyUSB1 -G /dev/ttyUSB0

Based on the information we’ve found thus far, it seems that ArduPilot only supports a maximum of 6 serial ports by default. Is this true? If so, how do we override it?

Thanks,

Ziv Kedem and Mohammed Khan

Hi @k.tareque,

You need to specify the ports with options you want to send to ArduPilot in the launch file. You can find this file following the path /etc/default/arducopter.

After you change the file, save it. Then, reload the configuration using the sudo systemctl daemon-reload command. Now you can run the ArduCopter with the sudo systemctl start arducopter command.

For more details, please take a look at the Installation and running guide.

The number of ports you can use simultaneously is restricted by the number of switch flags (A, B, C, D, E, F). Totally, there are 6 ports you can use at a time. It’s hardly possible to use more ports now.

1 Like