IMU Compensation not Working with NTRIP


I have bought an RS2+ as a base and an RS3 as a rover. All the setup has been fine until i try to use the RS3 to start plotting points. Its saying it recieves 38 Satellites and is also recieving my Ntrip base corrections. It wont change from float to Fix and the Tilt compensation never turns on.

I can only assume I am not setting something right.

Help appreciated!

Hi recall having a very similar problem. And I found out that the problem was my access code for my ntrip installation. It is case sensitive.

Hi Sam,

Welcome to our community!

Tilt compensation works only with a FIX solution. Once you get FIX, you can go through this guide to start working with tilt compensation. But first, let’s see what can be done to obtain a FIX solution.

In your email with the simple system report, I saw that you’re streaming corrections with Emlid Caster. It operates properly if you have a stable internet connection on your worksite. Is your rover continuously receiving corrections? An unstable internet connection can cause delays in correction streaming and, thus, a FLOAT solution.

1 Like


The rover is is definitely connected to a stable SIM card internet connection but currently I just cant get a fix on the rover where ever I use it. Its seeing 40 satellites. Just doesn’t seem to ever get a fix.

Hi Sam,

I see. A FLOAT solution can also be connected to environmental conditions. As the next step, I’d like to check the quality of your logs. Let’s configure your receivers for RTK with Emlid Caster and place them so that they have a clear sky view and are as far from obstacles and buildings as possible. After that, record the following logs with your receivers at least for 10-15 minutes:

  • UBX raw data log on both units with enabled raw data debug option

  • Base correction log on the rover in RTCM3 format

  • Position log on the rover in LLH format

Once everything’s recorded, please send all the data to I’ll take a closer look at it.