I want to use only LSM9DS1 in APM

I tried to calibrate the acceleration using Mission Planner, but it failed.
I have tested the IMU sensor and found that the MPU9250 acceleration does not work, but the LSM9DS1 works fine.
Is there any way to disable the MPU9250?

Hi @hsa.ghostforce,

Welcome to our community forum!

How did you find out that MPU9250 doesn’t work? Can you run a C++ or Python example with it and post the results here?

Nevertheless, if you need to disable a particular IMU, then you can use the INS_USE parameter in Mission Planner. For more details, please check this part of the guide.