I have a question about the navio2 software

I’m using navio2 connected to raspberry pi.
But I have a question so I post a question like this.

  1. I downloaded the image from the link below and uploaded it to the sd card to boot successfully.
    And I want to automatically run and create my own program on the downloaded raspbian image.
    So I wrote the name of the program I want to run automatically in /etc/profile.d.
    cd /etc/profile.d -> sudo nano kk.sh -> #!/bin/bash (enter) -> /home/pi/a.py
    As above, we did #!/usr/bin/env python in the first line of the program we want to run automatically.
    Finally, we finished with sudo chmod 777 a.py.
    But then when I reboot, there was no problem entering id and password, but then there was no place to type the command.
    Is there a problem if I do this?
    Please let me know what I should do if I want to run my own program automatically.

link : http://files.emlid.com/images/emlid-raspbian-20200922.img.xz

  1. I am making my own raspberry pi using raspberry pi cm3+ (compute module 3+).
    But I have a question here.
    Does the cm3+ module function normally when the GPIO PIN, 5V, 3.3V, and GND are configured with pin map such as raspberry pi 3b+?
    The above situation is based on the assumption that GPIO MODE in raspberry pi 3b+ was done the same.
    For example, if raspberry pi 3b+ has GPIO 1 as ALT0 and GPIO 2 as IN, then cm3+ has the same GPIO 1 as ALT0 and GPIO 2 as IN.

  2. Can’t I use it if I run raspberry pi without connecting navio2 later?
    Is there only a reboot?
    This question assumes raspberry pi says after booting complete and entering both id and password.
    I would appreciate it if you let me know if you know how.

Please check it.
Thank you.

I solved the first and third questions.
In the first question, AutoPlay program solved the problem by writing down the file you want to run at the bottom in “sudo no /etc/profile”.
For example, "a.If “py” or “a.c” is present, it is written at the bottom of “/etc/profile” as follows:
python -> “sudo python /home/pi/a.py &”
c -> “sudo ./a &”

The third question was to enter the command “sudo systemctl start aducopter” in the navio2 doc.

The second question was someone who had already posted on the Navio2 community.
link : Navio2 working on raspberry pi compute module 3

But what I’m curious about is whether navio2 works normally when configured like above.

I wrote the contents as above, so please check if it’s what I’ve been working on.
Also, you can tell me if there is a better way.

Please check it.
Thank you.

Hi @osung1598,

Navio2 is fully compatible with the Raspberry Pi boards that are listed here. We haven’t tested Navio2 with Raspberry Pi Compute Module 3, so I can’t be much of a help here. I believe it might also require the changing of the image configuration itself.

Hopefully, someone from our users who’s experienced with it can share their thoughts.

Thank you for your reply.
If you want to connect to Navio2 using raspberry pi computer module like me or if you have succeeded, please write a comment.

And can I ask you a question?

Suppose you have raspberry pi booted without navio2.
And if we later connect the navio2 and do the sudo systemctl start arducopter as mentioned above, does it work normally?

Hi @osung1598,

We can only assure that it will boot correctly when you attach Navio2 to Raspberry Pi beforehand.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.