I cannot get the GPS to work with C++ example or Python Example. I tried for over 1/2 hour outside with clear sky

I cannot get the GPS to work with C++ example or Python Example. I tried for over 1/2 hour outside with clear sky

I have the following hardware combination ….
Raspberry Pi 3
Navio2
GPS antenna (ANT102)

I am using the latest image “emlid-raspbian-20170323.img.xz”

I cloned https://github.com/emlid/Navio2

I have read the docs (https://docs.emlid.com/navio2/) I went through the “Navio2 for developers” section and all the sensors work except for the GPS

when I make and run ./gps I get …
Ublox test OK, then I get 0.000000 for Latitude and Longitude (gps Fix status: no fix). I run this for over 30 minutes outside with a clear sky with the same 0.000000 result for Latitude and Longitude.

I get the same result for GPS Python example.

The both are NOT running at the same time.

I suspect it has something to do with the drivers. The documentation that came from https://github.com/emlid/Navio2 talks about C++ drivers but I do not know how to install them. Also there is a requirements.txt file in the Python sub directory but I do not know what to do or how to use it?

I have joined the Emlid Community and read through the “Getting Started” section on the Emlid Community.

Any help greatly appreciated

Hi! Let’s try to find out what’s the problem.

Please try to check it in u-center:
https://docs.emlid.com/navio2/common/dev/gps-ublox-ucenter/

Is there any satellite visibility? Please post a screenshot of u-center with receiver connected.
Try to move the cable slightly and see if it changes anything.

Hello Mikhail
Thank you for replying to my post

Here is the output from ublox-ucenter


There are no satellites visible, no fix, no nothing.

I started ./ubox-spi-to-tcp 5000
waiting for connection
connection accepted

I must be doing something fundamentally wrong. I have never used a GPS module before.
Could you please tell me the fundamental steps to “talk” to the GPS unit?

This is what I do. I have the Navio2 connected to raspberry Pi 3 and have the antenna connected to the Navio2 sitting on a bench outside my house. I start the Raspberry Pi 3, ssh into it from my Mac using my WiFi. I start ./ubox-spi-to-tcp 5000 I then connect to the Pi from ublox-ucenter running on a Windows VM.
It connects but I do not see any satellites and do not get a fix. The LED on the Navio board is not on.
It seems like the Navio is not “talking” to the GPS unit. I have tried moving the antenna as you suggested without any success.
Once again I appreciate your help
Regards Frank

Did you use screws from the package to firmly fix Navio2 to the Raspberry Pi?

Please run the following in the command line:
emlidtool

What is the output?

Hello Mikhail

Yes I screwed the Navio2 to the Raspberry Pi3 with the screws and spaces provided
I did a screen capture of the emlidtool command.

Also I took a picture of my test setup. I put a TOM TOM near my test setup and it locked onto the satellites and got a fix.

I am using a 5v 2amp supply to power RaspberryPi3/Navio2. I also tried using a Lipo battery and the cable that came with the Navio2 but still no satellites and no fix.

I don’t know what I am doing wrong?

Once again thanks for your help

Regards Frank

Thanks for running the tests.
Most likely this is an issue with the antenna.
Please contact support@emlid.com and provide your order number and the link to this thread, we will arrange a replacement.

Hello Mikhail

Ok I will do that. Just a few questions to get things clear in my mind.

Basically when you turn the “Raspberry Pi3/Navio2” on and the antenna is connected the “Raspberry Pi3/Navio2” GPS module (Neo-M8N) will start trying to find satellites and get a fix and it does this without needing to start any software programs. Is this correct?

So the purpose of programs like ./gps is to go to the GPS module and read the data ( latitude and longitude etc assuming you have a fix ), they don’t start GPS Module. Is that correct?

Is there a visual indication that the GPS module has got a fix? Does the LED on the “Raspberry Pi3/Navio2” flash? Does it go solid green?

Regards Frank

Yes, GPS module calculates navigation solution independently and the programs only read the data.
LED is not connected to the GPS module, so it will also display status only when some program reads the data and sets it.