How would I calibrate my ESCs individually?

Hello - Can someone please help me?

I am building a drone with a Navio 2 and RPi 3B+. My issue is ESC calibration. I’ve looked at all the posts and I still am not able to tackle it and get the motors to spin.

ESCs: SimonK 12A brushless
Motors: 1804-2400Kv brushless DC motors
Using MissionPlanner AP.

When I plug in the battery the light is green for a while, then flashes red and blue then keeps flashing green afterwards continuously (2 beats at a time). I changed the parameter for ESC_CALIBRATION to 2 then also tried 3 - it flashes the same… Am I not able to enter calibration mode - what is wrong??

The ESCs all beep in unison when I connect the battery does that mean it’s already calibrated?? In that case why won’t the motors spin although I arm them (5 second right yaw)

I’ve seen in most posts that they calibrated the ESCs indivually with their recievers and it worked afterwards. How can I calibrate individually - what does this mean?

Guys I beg for help - I’ve been stuck for too long. I would be so grateful for your insight.

I used the ESC calibration button then followed the steps.

My ESCs are continuously beeping nonstop - what am I doing wrong??

So you clicked the button, pulled the battery, and then plugged it back in, and it starts beeping (as it should)? Then, when you pull the battery so power is off and then plug it back in, does the beeping continue or stop?

It continues and persists forever.

The messages give me a clue as to what I need to do but I don’t know how to fix it.


I disabled all pre arm checks and the motors work fine then obviously - so nothing is wrong with them. It’s a configuration issue? Please give me a clue as to how I can fix it if you got it. Thanks for your reply.

Hi, yes, the issue doesn’t seem to be with your ESCs at all, then. They are beeping in warning, but I don’t know if anything is actually wrong with your ESC setup. This is a PWM issue, in that your RC input from your receiver is currently below what Arducopter thinks should be the lowest signal it will ever get in flight.
What kind of R/C transmitter and receiver are you using? Are you using SBUS or PPM?
1.Double check everything is setup correctly with your transmitter and receiver. Especially if it’s any kind of OpenTX setup, update to the latest firmware before you do anything else.
2. Calibrate the transmitter itself through its own firmware on the transmitter if it has that option.
3. Next, run the Arducopter radio calibration under Mandatory Hardware. Follow the prompts and be sure to leave the throttle down at the end before you click Done.
4. Hit CRTL F and click Reboot the Pixhawk button, or unplug the battery on your UAV and then plug it back in and wait for the RPi to boot the Navio2 and reconnect on your network.

If that doesn’t fix the problem, you’re going to have to edit the values in Mission Planner to something below what your radio is currently outputting as its “low” value.
For example, go back into that Radio Calibration page under Mandatory Hardware in Mission Planner and look at the number it gives you for the throttle channel when the stick is all the way down. Let’s say it gives you a number like 980. You would then go to the Full Parameter List and search for FS_THR_VALUE and edit the number to something like 950. Here is a pic of that.

You will have to do the same for each channel that is fail-safing if you have an R/C setup that for some reason is giving low values that are too far below whatever Arducopter thinks is a “normal” low value after calibration.

The reason for this, is that it thinks it lost radio contact if your PWM signal drops below that threshold anytime in flight, and will fail safe, triggering an RTL situation.
Hope that helps and best of luck getting her in the air! :slight_smile:

Hi there!
Followed advice given. The motors are spinning just fine now!

I installed the props and checked all motor directions before trying to fly. The drone won’t take off however.

Looks like this:

I put throttle to full and just then it slightly lifts up from one side only. I tried swapping props and tried all combinations. It won’t lift up. I can’t tell what the issue is and why air isn’t being pushed down properly.

Before this setup - i was using librepilot and a cc3d. changed to a pi and navio 2 (just removed the old cc3d). I allocated the positions of the motors accordingly to ardupilot’s docs. Could there be something else I need to configure and it’s just a software issue??

Hi @sealion420,

May I ask you to connect ESCs directly to the receiver to check if everything is fine with these ESCs?
Also, it would be of great help if you could record a video of the drone’s behavior.

Hi again,

Thank you for your reply.
I resolved the issue now though.

Hi @sealion420,

Glad to hear you resolved the issue!

Could you share with us what caused the issue?:slightly_smiling_face:

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.