How to test motors with navio 2

I have finally assembled my drone and I would like to test the motor’s spinning direction.I don’t have any radio because my drone is fully autonomous and I would like to test everything .I don’t know if the motors are spinning in the right direction and I would like to check that. How can I do it

Connect to mission planner program via UDP via ethernet then go to the installation section and there is an engine test tab in the optional equipment section.
you can test each engine


Congrats on your build!

As an addition to the @yalcinkayaafurkan answer, here are the guides on how to do it in the QGroundControl and Mission Planner respectively.

1 Like

thanks for replying me . i have a problem in ESCs calibration after i lunch ardupilot one of my ESC keep beeping so what is the problem .
Nb : i don’t use a RC because my drone is fully autonomous

Could be fully autonomous when debug and tuning is done… Until that, RC is needed.

i have found a solution by using the " Semi Automatic ESC-by-ESC Calibration " mentionned here and it works fine i hear a number of 3 beeps (my battery is 3S) and finally a single long beep . but after the calibration is done the navio 2 led keep blinking in yellow (i think he should blinking blue ) so what is the problem

did you calibrate the accelerometer and the compass?

you have correctly set the flight mode and the gps is working?

If you are set to an automatic flight mode but the GPS does not take you will not be able to arm the engines and get the drone off the ground.

Finally, if you say that you have no receiver or you not use a transmitter , you must disable relative pre flight controls.

@mgonline i have calibrated the accelerometer and the compass successfully. but i have a problem in the GPS (no GIPS fix) , Can i fix it plz .
and how i disable relative pre flight controls

Without a receiver and a transmitter I think is not a good idea disable the safeties. In any case if you use QGround control as ground station software in the setup menu - safe you can disable the pre flight check.

In ardupilot i think is in user parameters setup page.

For GPS I don’t know what to tell you. mine outdoors takes a good signal in a few minutes.

@mgonline i get an “unhealthy GPS signal " message on mission planner and when i lunch the GPS exemple from emlid i get " gpsFix=0
Longitude=12173742 Latitude=483867526 height=11909230 hMSL=11863054 hAcc=4294967295 vAcc=3825423872” and sometimes i get zero value in the all parameter

even in open space the gps takes a while to take at least 7 or 8 satellites let’s say 4 or 5 minutes. If you try to make the connection inside a building it will never take well. If you do it outside but you are close to tall buildings or metal fences or high power lines the signal will never be good. Finally, it also depends on whether you have areas that are off-flight or not.

Did you manage to get the copter up without a radio?
I am trying the same thing and looking for any guidance since you went ahead of me…

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.