How to setup E368 HUAWEI 3G dongle to Reach M+

I would like to setup this 3G dongle to feed ntrip corrections to the reach M+

I connected the Reach M+ with SSH
image installed:

root@reach:~# uname -a
Linux reach 4.15.10 #1 SMP Tue Jul 17 11:25:25 UTC 2018 aarch64 aarch64 aarch64 GNU/Linux

First, I tried to check if the dongle was really detected as a modem but I am not really familiar with Linux

root@reach:~# lsusb
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 1546:01a8 U-Blox AG
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 12d1:1446 Huawei Technologies Co., Ltd. HSPA modem
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Second, I was looking for a script to start “wan” interface where pin code and apn are entered.

I tried to install “sakis3G” script but some dependencies are missing on current image

for instance opkg update is not pointing to correct package folders

root@reach:~# opkg update
wget: server returned error: HTTP/1.1 404 Not Found
wget: server returned error: HTTP/1.1 404 Not Found
wget: server returned error: HTTP/1.1 404 Not Found

It will be nice to get a tutorial to setup this type of 3G dongle. It will be useful for many customers


Hi Rene,

We’ll look into this issue!

1 Like

Dear Dmitriy

a) I did more tests with 3G dongle

If I insert a sim card without Pin Code, the dongle is detected as a “Modem”
Why a pin code, The modem is detected as “locked” then few second later the 3G dongle is detected as “mass storage” (according system log)

Currently, I cannot do more tests because my 3G dongle works correctly only with the M2M card with Pin code (the pin code cannot be removed).

I tested on windows computer and the 3G dongle could not be connected to any network with other sim cards tested without pin code. I am waiting another 3G dongle to do more tests

The connection should probably work well with a sim card without Pin Code.

Could you, please, add a “cellular” menu in Reachvew" to enter APN and pin code?

B) OPKG repositories looks wrong


Hi Rene,

We couldn’t reproduce your issue. Could you please try a different dongle?

Dear Tatiana,

I will keep you update as soon as I will get a new dongle


1 Like


I got a new Huawei E3372 lte dongle.
I tested on W7 computer with 2 sim cards (one from my phone without pin code and on M2M with pin code). I get connected automatically with the sim without pin code and I had to enter the sim code for the second one . the new network created looks to be RNDIS type.

On reach M+, the dongle looks to be see as a modem but I could not get the connection on. the led is flashing blue. Some packet are probably missing.

I am not familiar with Linux OS. Which logs do you need to debug?


Hi Rene,

When you tested E3372 with a sim card with no pin, did it work with Reach?

Dear dimitriy,
E3372 with sim card wihout pin code:

No i could not get the connection up.
The dongle led is flashing blue = the system is trying to enable the connection.

Do you need a particular log to try to locate the issue?


Dear Dimitriy,

I connected the reach M+ to lab power supply to monitor the 5V supplied.
the reach M+ needs around 250 mA with a pick at boot sequence of 500 mA
when the #G dongle is connected, there is 50 to100 mA additionnal current needed.

Do you need the full system report on your PM

I tested again dongle EE3372 with sim card wihtout pin code, I got direct connection to internet on my W7 computer


Hi Rene,

One of the possible reasons why it might not work is a power supply, that is required for the modem. Reach can turn the modem off in case it requires too much power. Or there may be an issue with the USB port. You can test it by plugging in Reach M+ USB flash drive. If it’s powered, the USB port is ok.

The other reason is connected with modem possibility to work with Linux. The way Reach M+ establishes the connection with an LTE/3G modem might work not for all models. I’m afraid it’s hard for us to test Reach M+ with all the existing models, taking into account the fact they can vary a lot depending on the region you purchase it.

So it’s unlikely the remote session can help with resolving the issue. All I can advice now is to use one of the modems we tested with Reach M+ (ZTE MF823 or Huawei E171).

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.