How to set up APM Planner 2.0.15 with NAVIO APM:rover firmware

Hi Guys,

I had to wait for 45 days for the sbus2ppm converter arrived… but now i am back!
Now I am a linux guy so I have APM planner(not mission planner) 2.0.15 on my linux laptop
I have build the APMrover on the NAVIO ran it et voila all connected works straight away…

But now planner thinks that the NAVIO is in a copter but it is in a rover…

So when I go to install firmware , it says it cannot download firmware while connected to mav-link.

In the planner the connection icon upper rright corner is DISCONNECTED but I do have connetion…

on the pi I have started rover like this:

pi@navio ~/Navio/APMrover2.build $  sudo ./APMrover2.elf -A udp:192.168.178.20:14550
0
Opened /dev/spidev0.0

When i click on the connect icon i get an error saying Device or resource busy… see attached screenshot

So now i am stuck, what to do?

So I cannot tell APM Planner it needs to setup for a rover…

Do I need to download firmware to the navio in the first place?

thanks

hugo

Hi Hugo

I don’t think you need to upload the firmware as it is already set on the pi. It looks like you might have your connection port set incorrectly.

Martin

Hi,

if you use udp, the APMplanner is set to pick the connection up automatically. I think there is an option somewhere to disable this behaviour, but I can not find it right now.
The connect button has no function with udp, but if you are using radio telemetry modules, the device usually is ttyUSB0. ttyS0 is a linux serial port.
APMplanner seems to be a little unaware that there is something like APM:rover.
APM:copter seems to be their main target.
So there is no way to tell APMplanner it is connected to a rover.

ok thx Martin for you reaction…

I am new to setting the whole thing up and a bit overwelmed here…
I have a crawler that I want to use, and a Taranis plus with openTX on it

When I ssh into the raspberry and execute the apmrover2 the mission planner starts, connetcs and starts talking about mode changes ending in a “hold” mode.

first thing which is strange is that i have two axis that i can steer, my transmitter is doing that as i can see in the failsafe check but this is not passed on by the navio to the second servo(back axle steering, so only the front axle steers. throttle is ok. i also have a DIY gimball for my picam but I cant get it to do anything.

my biggest issue at this point seems I cannot select proper “flightmodes” any tips there?

how do i map switches of the transmitter to flightmodes?

btw the upper right corner of APM Planner is now grayed out including the connect icon but i do seem to have a connection…

tx

hugo

ha thx ok,

yes seems i am connect alright…

but indeed a bit woried about how to set up the machine now…

all is indeed to configure for a copter… in the flightplan screen there is the icon of the MAV 001 that says it is a rover but that’s it…

below a ss from the APMplanner connected to my rover…

is there an alternative to APMplanner for linux?

You could try qgroundcontrol.

I would recommend to read through rover.ardupilot.com, to get the basic setup done.
The documentation for APM:rover is really outdated in some parts, so if you get stuck somewhere, please ask. I had to figure out alot of it myself.
I am not sure APM:rover supports two independent steering servos, you might need to use a y-cable, perhaps with a servo reverser.
You will need two switches on your taranis (one two position and one three position) or the 6 position rotary switch for the taranis plus to control the 6 flight(drive)modes.
There are many guides on the internet on how to setup two switches to put out six positions. You can download a dummy APM model for your taranis, too.

Hi Sebastian,

thx for your answer.

so do you mean the channel mapping si fixed? I cannot change the mapping in APMplanner or APM:rover to my specific configuration?

didnt know that.

http://rover.ardupilot.com/wiki/apmrover-setup/

Input Channels:

RC Rx > APM Input
1 > 1
2 > 3
5 > 8
6 > 7

Output Channels:

APM > Car
1 > Servo
3 > Motor/ESC

it has a fixed table but I thought i could tinker this around?

hugo

Yes you can! :smile:

There is a parameter named “rc_map” in the full parameter list. rc_map_throttle etc. There you can change which channel order you need. APM default is AETR (Aileron, Elevator, Throttle, Rudder). I am using TAER, for example.

Hi Hugo,

I just installed missionplanner 1.3.19 under Ubuntu 14.10.
I followed the steps in this rcgroups thread:

http://www.rcgroups.com/forums/showthread.php?t=2179591

To get it to run properly I had to start missionplanner as root with:

sudo mono missionplanner.exe

hi Sebastian,

I do not like to install wine or mono on my laptop…

Any idea this rc_map is also available in APM Planner? i understand now the issue with 2 steering servo’s out from Navio will not work ootb i guess.

APM Planner now runs fine.

I am also interested to stream gstreamer from the pi to my laptop (basically that works fine) but INSIDE the primary flight display of APM Planner… any idears there?

thx

hugo

Hi Hugo,

all the settings are in the full parmeter list.
You can access it with Apmplanner too.
You might have to set the apmplanner to advanced mode. The option is in the file menu.

I know missionplanner supports video in the PFD screen from video sources available in Windows.
Qgroundcontrol supports video display through video over mavlink, but only with the pixhawk/px4 firmware.
I do not know about such a feature in apmplanner, but it is in development, so they might add it later.