Emlid

Community Forum

How to properly import GCP to Civil 3d


(Avelez) #1

I collected some control points but when I open the DFX file, the point are not to scale. They are really close to each other. Plus when I mapiinsert the orthomosaic, the gcps are not even inside the imagery. I am using a phamtom 4 and recap photo to process. I almost sure is a configuration problem. How do I know the coordinate system, the projection, state plane? There’s no clear information out there to aliening the gcp with the orthomosaics.

Help please.


(Michael Lambert) #2

The projection and coordinates are most likely your problem. If the cad file is not on true state plane then we call that a shift. You also have to watch out for scale factors so you might look on your plans where the benchmarks are and see if they applied a scale factor. It is usually 1.00012 or 0.9998. I rounded but it’s usually in that range.

Are the points coming in close to your site or are they way off? There might be a scale factor from architectural to civil if they are far off. I have heard many people having problems with recap and data with actual coordinates.


(Avelez) #3

EPSG on the emlid says is 4326. The control points are taken in augusta georgia.
How do I set projection and coordinate system in civil 3d? The dfx with the point are visually fine, but the position where the ortho is and the points are way off. The ortho is place geo-spacially in the right place, but the point look like their are in the ocean somewhere in the south.


(Timd1971) #4

do some youtube searching for coordinate systems and civil 3d autocad etc help. There isn’t a whole lot and it’s pretty poor what I had found a year ago or so.

You’ll need to load the correct coordinate system for your region where you collected the points such as the GA state plane or NAD83 and your UTM zone 17S (north of equator). This way all of your points will fall within your correct coordinate system region to create drawings etc.
http://www.dmap.co.uk/utmworld.htm


(Zinedine) #5

Can you upload your csv file here ? if possible of course, and I will make you a tuto…


(Avelez) #6

Ive trying to using different coordinate systems but one of the biggest problem is the scale of the ground control points. they are extremely smaller that the orthomosaic.

ge4rg


(Zinedine) #7

You have to transform longitude latitude elevation to XYZ (corresponding to your WGS84 UTM Zone for example)


(Avelez) #8

How do I do that?


(Avelez) #9

How to I resolve the scaling issue?


(Zinedine) #10

First time you need to transform your coordinates from deg to meter in your case transform to (WGS84) (UTM) Zone 17 North using Coordiante converter you will find a lot in the net, for example : https://twcc.fr/en/# after that import them respecting the format accepted by Civil3D (For example NXYZ taking into account the separator)


(Avelez) #11

Thanks for the info. I am still trying your methods. Im about to call it a day, but I wish I can have more support from anyone that knows how to take emlid coordinates ground control points and set a drone map under it and be LINING UP with the GCPs.


(Michael Lambert) #12

Yes, Emlid uses WGS84 for both horizontal and the ellipsoid. If you go into drawing setup you should be able to set it up as your local state plane and NAD83. You can enter the scale factor there as well if there is one. Normally it will not import the GeoTiff if a projection is not set in drawing setup. Did you check coordinates on the GeoTiff to see if it was really in the right place? Maybe you have a plan benchmark or something you could enter in to verify. Better yet two so you can check rotation too. Can you share the GeoTiff and and points file?

Do you mean DXF? That is the generic CAD format.


(Forest King) #13

avelez and I have been still been struggling with this process but the suggestions from this forum so far have helped. We have had the same issues with Pix4D and Recap Photo. In Pix4D I use WGS 84 (EPSG 4326) to import the images since that’s what the Emlid uses. For output coordinate system I use NAD_1983_StatePlane_Georgia_East_ FIPS_1001_Feet (also tried using WGS84 for output system in pix4d and Civil settings) and that is the same system I use in the Civil 3D drawing settings. I’m not sure if this matters but if I upload the ortho KML file from Pix4d and the GCP’s from the emlid into Google Earth, everything is where it supposed to be. Also when in Civil 3D when I turn on aerial maps, my ortho is perfectly overlayed in the correct location. The only thing that does not come in properly is the GCP locations. Sounds like we need to convert coordinate from Emlid and figure out scale factor?


(Michael Lambert) #14

Are you points in a local state plane or on WGS84? Make sure your units are setup correctly as well. If you have an existing CAD file with linework or other points does the ortho line up with them? If they are in a state plane then I would definitely look for a scale factor.

I have had similar happen and the drone data would come in 300-600ft off depending on the job because of this. I thought something was wrong with the drone data, then I found the scale factor. When they are that far off we would bring in a Google Earth image and move the CAD to that so our drone data would be relevant moving forward. This is tough because you then have to remember to do this to future revisions. Make sure the drone lines up with the Google Earth import.


#15

It sounds like an issue with point importing in the DXF or CSV file format, specifically. Confirm the DXF coordinate system as shown in Civil 3D. Follow the advice of @Zinou. Can you also confirm the coordinate system of the TIFF as shows in Civil3D? It may be in issue on how Civil3D is handling different coordinate systems and how they are defined by default on import.

My suggestion, if still grief try converting your DXF or CSV to shapefile before bringing into Civil3D. Reproject to state plane from WGS84 in QGIS. Set coordinate system in Civil3D and import your data.

Eh, they are close but not exact. But close enough for comparison! That is because the ortho KML file from Pix4D is in WGS84 Web Mercator (3857) regardless of your projects coordinate system and all your other data. Emlid is WGS84 (4326).