How to make a default IP address?

I have ReachView version: v0.4.9 and Reach image version: v1.2

I’ve always wondered, why do the IP addresses usually change when the reach units are powered off for a day and then powered back on?

Also I’ve been using my two reach units on my home router for a long time, but I want to do some far away off line post processing with one of the reach units and control the starts and stops etc. with my android smartphone. The way i did this is turn on my phone hotspot, I then plugged the reach unit into my desktop USB port, finally I scan for wifi signals using the Edison Board Configuration Tool and connect to the phone hotspot successfully. The only problem is reach always wants to default to the router IP after I unplug reach from the desktop PC and back into the portable USB power bank. The only way I got it to connect to the phone after unplugging from the desktop was powering off the home router first, then connect using the Configuration Tool, unplug reach from the desktop PC, plug back into the portable USB power bank, then it would finally connect to the phone. This would be a pain to do each time, so is there a way to make the wifi connection priority #1 for the Phone hotspot IP and #2 for the home router IP? It would be bad to be out in the field and loose signal or the battery goes dead thus the IP would default to the home router IP and I would not be able to connect to Reachview.

Anybody know how to solve this? Thank You.

ssh into reach
user: root
pw: emlidreach

open wpa_supplicant file:
sudo nano /etc/wpa_supplicant.conf

insert according prioritys to the according ssids: (number between 0 and 100)


and your home router:



Also remember that you can always connect to ReachView by turning off all familiar hotspots/wifi before turning Reach on. Then Reach will make it’s own hotspot. When you connect to the Reach hotspot, the IP address is always

The only problem with this method is that Reach will not have internet access through your smartphone. (e.g. No NTRIP)

1 Like

Thank you both.

I tried turning off the phone, going far from the home router, and then I turned on reach and waited for the multi color blink. Finally I turned on the phone and phone hotspot. If I enter in a browser nothing comes up.

I then I tried to get in using putty but I don’t know how to properly use it.

You almost had it!

  • turn off phone hotspot
  • turn off router (or go away from familiar wifi networks)
  • turn on Reach
  • wait for multi color blink
  • use phone to scan for wifi access points
  • see Reach hotspot (reach:9c:3a or similar)
  • connect to Reach hotspot (Reach gives your phone an IP address 192.168.42.xx)
  • use phone browser to go to
  • see ReachView status page!

I got it to connect, Thanks! I may try to learn about putty and do what was suggest at the top in the future, but this at least solves my problem for now.