How to get to emlidtool window as shown in the docs

First time setting up Navio2+RPI3.

There was no issue with downloading the image and flashing to SDcard. I am also able to SSH.

Now I am on this page, where the confusion begins.

I have followed all the steps but couldn’t find how to get to this window?

Though following all the text commands worked OK without any issue.

I also tried to run “emlidtool test”, which gave the following output.

As of now Navio2 is connected to RPI3, no other peripherals (receiver, ESCs, GPS etc.) are connected.
And it’s configured to run Arducopter 3.5.5 on Navio2.

[edit]: the “pwm permission denied” issue was resolved after using “sudo emlidtool test

Try to run sudo emlidtool ardupilot

Thanks, but that just shows the textual help

Looks like you’re using the old version. You should update it with sudo pip install -U emlidtool

finished with lots of errors and the output of “sudo emlidtool ardupilot” is still the same

Are you sure that you’re using the newest image? You can install libffi manually or reflash to the new emlid raspbian image.


Look like you have an “old” image. With latest you should have emlidtool 1.06


I downloaded Jessie from here, assuming this too will work seamless but it doesn’t seem the case. Ok, I will try Stretch now.

Will that be a good idea to remove the Jessie from the list or at least leave a note there for newbies as it doesn’t align with the latest documentation.

Thanks Marc, this seems to be the issue.
I will download and flash Stretch now, as you indicated.

Hope it will solve the problem.

Thanks everyone, the issue has been resolved after flashing the latest Stretch image.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.