How to change the SERIAL0 baud rate in Mission planner

Hi Mikhail. I been following this thread. I want to know where do I change the serial0 baud rate in Mission planner? Ive been at this for months as well and have not gotten anywhere. I’m very new to this!

Hi @logo_jones,

You can change the SERIAL0_BAUD parameter in the Full Parameter List of Mission Planner. It might be more convenient for you to find this parameter using the search bar. I’ve attached the screenshot below that you can check out.

Thank you. I will try this to see if I can get my Telemetry units connected.

I tried changing the Serial0 baud rate but I guess that only works once the Telemetry are connected. I can connect to mission planner via UDP but I imagine I need the telemetry to connect to actual use outside. My Telemetry units are not connected like the thread I have been following so I imagine I have a different issue

Hi @logo_jones,

Could you please specify how you connect the telemetry modems to Navio2? Also, it’d be helpful for me to check the settings in your launching file.

I have one that is set up on the actual drone. The telemetry is connected via UART. The other is connected to the back of the computer into a USB slot. I am powering the Raspberrry Pi via usb as well. Here is an image of the one that is attached to the drone. I also read that it is possible they are not running the same firmware. I have a FTDI usb to ttl arriving today to test this theory. I do have all of the settings correct in the launching file as well

Hi @logo_jones,

Have you had a chance to check it with your setup? It’d be great to hear about the results.

I did get the FTDI cable in but I have not had a chance to look into it yet. I will this weekend and provide you with an update. Thank you for the assistance.

So I tried updating the telemetry with and FTDI cable it was not exactly what i needed to update my current module. I I think purchasing a new set that has the ability to connect both components to the computer may work and fix my issues. I will let you know if that solves the issue.

Hi @logo_jones,

Thanks for the update on this!

I ordered this today. Says it will take about 3 weeks to arrive. I am hoping this works and then on my next build I may have more knowledge. Thank you for taking the time.