How to achieve 14Hz update rate

On Emlid website (Reach M2 and M+ | RTK GNSS/GPS modules for high-precision mapping), it claimed that “RINEX logging update rate: Up to 14 Hz” for RS+ with M+. I have exactly the same devices, but could not achieve the 14Hz.

If I selected “RTK” to 14 Hz, I have to lower “Position output” to 1Hz.
If I want to set Position output to the maximum, which is 10Hz, I have to set “RTK” to 10 Hz.

Can someone tell me how to achieve the claimed “14 Hz” update rate?

1 Like

Disable satellite constellations until you can select the 14 hz option

1 Like

@wizprod Thanks for replying. Could you please provide more details? I can setup RTK update rate to 14Hz, but once I do that, “Output position” update rate will become 1 Hz automatically. And the signal update I got on my computer is 1 Hz.

1 Like

Anyone know?


I am using Reach RS+ as base and Reach M+ on a robocar as rover. The robocar uses RTK GPS signal to navigate. The car is running very fast (> 20MPH) so I need high GPS update rate.

For RTK, I used to get 14 update per second which is OK for me.

However, today I upgraded my iOS ReachView app to ReachView 3, but it also upgraded my M+ firmware. (This is not thing I wanted to do). Now I only get 1 update per second. This is not acceptable for my application.

My M+ position output format is NMEA. I found that if I changed the position output format on M+ to LLH or XYZ, I still got 14 updates per second. But I really need NMEA as I need to speed information.

The ReachView 3 user interface is very confusing, I do not know why people what to upgrade to that.

Could anyone help me with this:

  1. How to setup the RTK update rate to 14 frame per second in the new firmware?
    2, Or, how can I downgrade the firmware on M+ to before? (I actually do not know which version I used before.)
  2. I would like to block GBGSA message from sending out. How can I do it?

Thank you for help.

1 Like

Hi George,

We’ve been in touch in PM over this but let me quickly repeat my answer. Hopefully, it’ll help if someone else has the same question.

So, to achieve the 14 Hz in position output, you indeed need to have the RTK update rate higher than 14 Hz or the same. For that, it may be necessary to disable some of the GNSS constellations.

Once you set it up, you need to configure the NMEA messages stream. For that, please use Reach Panel. You can go there just by holding the receiver’s name in ReachView 3 and choosing the Reach Panel option. There, go to the Position Output settings. You will be able to see the following configuration window:

Here it becomes really easy. Just choose the needed messages and their frequencies. That’s it, you’re good to go!

Let me know how it goes for you.

Also, I’d like to quickly add that we don’t support rolling back to the previous stable firmware from the current stable firmware. We thoroughly test the versions before putting them out. If you have any questions, it’s always better to contact us directly first.

1 Like

Hi @polina.buriak Thank you very much for replying.

I setup the update rate for RTK to 14 Hz. However, Then in the “Position Output” panel, I can only set the update rate to 1 Hz. Then when I connect this to my computer (Nvidia Jetson Xavier NX), I got only one update per second. The computer needs to received 14 updates to work.

I think only GPS will deliver the higheset update rate. Disable the rest as @wizprod mentioned.

@timd1971 Thank you for posting. You mean selecting GPS only, no GLONASS, Galieo, BeiDou etc. correct? Should I do this on Base or Rover?

I acutely did this on Rover before, it did not help.

I think u have to havethe same on both. It’s been awhile.

Just made the change, select “GPS” only in both Base and Rover, still did not work. I think the only way to get the 14 Hz update rate is to have the 14 Hz option in “Position Output”. I did not see it now.

Could some one help me with this question:
Suppose we connect M+ to a computer, is the update rate the computer gets defined by RTK update rate or the Position Output update rate?

Hi everybody,

Seems like we all got a bit confused here. Let me explain things a bit.

You can set up the RTK update rate to 14 Hz. It means that the solution will be recalculated 14 times a second.

If you need to receive the position data 14 times a second in your hardware, you need to set the same frequency to the position output option. The trick here is that the RTK update rate should be higher than the position output rate. Moreover, the position output rate should be divisible by the RTK update rate. A bit complicated, I know.

Here we come to the core of the issues here. We’ve discussed this case with our devs. Now you can set the 14 Hz output rate to all of the formats but NMEA. This feature is out because of internal algorithms code changes.

We understand the need for it, though. That’s why we’ll be definitely returning this functionality to the firmware. We want to support all the features we initially advertised.

I’ll keep you updated in this thread! Once it’s out, I’ll be in touch.

Edited: removed a typo.


So this lies the problem.

Yes, please put it back. Quite frustrating when features are “removed” midstream when relied upon.

Thank you.

1 Like

We’re on it!



I noticed if u disable GLONASS and BEIDOU, it will activate 14 Hz update rate. But I guess EMLID has temporarily disabled NMEA output though?

Will 10 Hz get you by?

Hi @polina.buriak Thank you very much for the support. I really appreciate that the Emlid team listens to the customer needs. I am looking forward to the new firmware.


@AutoCar, we’ll definitely let you know once the update is ready!


Hi everybody,

I’m here to announce the news! With our new 29 beta 2 firmware update we returned the possibility to set up 14Hz NMEA output for Reach RS+/M+ receivers.

Just want to note that beta versions mainly serve as earlier access to new features. That means that we usually don’t recommend them for important fieldwork. Still, we’d still be happy to see you try it!

Surely, we’ll announce when it’s added to the next stable release.

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.