Help with BLHeli_32 Passthrough

Hey,

So I’m trying to modify my ESC mode using BLHeli_32 pass through. However, I am unable to get BLHeliSuit32 to connect.

I am running an RPi4 with a Navio2 hat with Linux Navio 4.19.83 and ArduRover 4.0.0. I am able to connect to the drone with mission planner, I am able to get the ESC’s (Turnigy Multistar BLheli_32 ARM 21A) to function normally on the drone and the drone responds to commands. ArduRover 4.0.0 documentation suggests I should be able to use pass through, however I notice several of the parameters I would expect are not present in the parameter list in mission planner (SERVO_BLH_AUTO) or if I connect through MAVLink which makes me wonder if Navio2 does not support it?

I tried setting MOT_PWM_TYPE=4 and rebooted the controller, but it didnt show the parameters after that.

Any help is appreciated. Sorry if the solution is obvious - I’m a little new to this.

Thanks.

Hi @RedRocket,

Welcome to our community forum!

In the meantime, the passthrough feature is not realized in Navio2. You can connect the telemetry in standard mode as it is shown in our guide.

Hey,

Thanks for the reply. There does seem to be some confusion though on this and on similar posts.

I’m not trying to connect to the ESCs for telemetry - I’m trying to connect to them to change the settings within the ESC. ESCs that run the BLHeli firmware provide an interface for connecting to the ESCs to change the way they operate.

Many flight controllers provide a pass through option, where the flight controller talks to the ESCs on behalf of the user and relays commands to a PC via a USB connection. In fact this is such a standard feature on many flight controllers it took me some time to find a way to do it without.

Is there any plans to build this functionality into Navio2 boards in the near future?

Thanks.

Hi @RedRocket,

Thanks for your request. We are planning to add this feature in the future versions of Navio2 images, however, there are no ETAs for it.