Help needed

Hi.
Ive been trying to get to grips with using the Emlid reach Rs (used as my rover) and my Rs+ (used as the base) I want to use them for plotting GCP’s so that I can use the for photogrammetry with my drone.
I’m doing PPK because I cant find the best corrections service to use out in the field.
My problem is that when I process the logs with the CORS and clock data the RMS is still high (I one case 50mtrs) my last attempt got this down to 1mtr but its still to high.
I have updated both to the latest software 26.2 and have looked on emlid docs and followed there set up but it still does not improve the results
I would add the file to this but don’t know how. Could someone PLEASE help me or I’m at the point where I may have to sell them and buy something I can use (aeropionts)

What I need is advice on setting up the units for PPK work, Information on where to download CORS and clock data so I know I’m getting good information (UK Based) and the correct way to process the base log to get the base position and the rover logs so that when I use time space interval function for the time period for each GCP i get a low RMS that is usable when its put into Pix4d. so i get more accurate Volume data and a more accurate ortho.

If you would like the file then let me know and ill e-mail them to you or send you a dropbox link.

Thank you.

Here is a Google drive link to all the Logs from the base and rover as well as the CSV file. https://drive.google.com/drive/folders/1Xi5Nk8htptCdo0LuVk_6UJBRj3blqW0R?usp=sharing

Hi @sgeyeuk,

My apologies for the delay with an answer.

I’ve checked your data, and I have a 98% fix with default settings in PPK. You can find a screenshot attached.

Am I correct that processing with default settings in RTKpost isn’t successful?
Could you please check if you’re using the latest RTKlib version from our docs?

As an alternative, you can try to process your logs in our new PPK software - Emlid Studio. We have just released the beta version.

Please keep me updated on your progress.

1 Like

Hi what settings did you use? No matter what settings I used the results were poor. Can you share your process for obtaining the base location and processing the rover logs? Did you use the cors data?
The rtklib version is 2.4.2 (I think, not at home right now) I’ll down load the emlid studio when I get home.

Hi Thank you. I’ve had a look at Emlid studio and i got the same result but how can i get the plotted points for each GCP? In RTK plot i would use time span interval. Second what i am trying to do with my PPK work is to correct the position of the base using CORS data, then correcting the GCP location comparative to the base so when i put the images of the site and the GCP locations into Pix4d i get better results. At present i get around 2mtr RMS. How can I improve this?

Steven,

I used Emlid Studio beta 6 for PPK. Please find my workflow down below:

  1. Static post-processing using your CORS obs data and your Base obs and nav data. I’ve received Base LLH coordinates with a fixed solution. The settings were as shown on the screenshot, and the Solution for static mode was set to Single

  2. Kinematic post-processing using obs and nav data from the Rover and obs data from the Base. Please note that I’ve entered acquired LLH coordinates to the Base position. The resulting track has a 98,7% fixed solution. The settings were as shown on the screenshot

  3. For processing your GCPs coordinates use obs and nav data from the Rover, obs data from the Base, and your CSV file. You can check this guide about working with Stop & Go in our docs, it might be helpful for you.

I’ve attached some screenshots of the process.

Please keep me updated on your progress.

HI. So I’ve tried this a few time and so far i have managed to get the base location as Long 53.344803, Latt -2.640493, Ele 88.4114. These are the same as you show on the first image. On the second image it shows Long 53.366817662 Latt -2.552699127 Elv 99.6519 Where did these con from?
When i process with the first set of co-ordinates i get

When i process with the second set i get this


Which set of co-ordentas do i use and where did the second set com from?

When i try to use the stop and go function i get this.

As it the beta test version I have attached the report (i hope)
emlid_studio_e2696a8356d14d0dbd6c6d4ff8f366cf_windows-10_23.06.2021_20-45-08.zip (48.6 KB)

Hi Steven,

Thanks for the report! I’ve sent it to the development team. While we’re investigating an issue with Stop&Go functionality, you can process logs in PPK mode and then find coordinates of your points using the timespan feature of RTKPLOT.

Please find some comments on your reply down below:

  1. Coordinates from the second image are acquired after processing logs from CORS and Reach base in Static mode.
  2. After processing, you’ll receive a POS file with calculated coordinates. You can open this file with a text editor.
  3. Enter acquired coordinates into the base position window, choosing Lat/Lon/height, dd before PPK processing of the Rover track.
  4. Process in PPK mode with OBS data from the Base and OBS and NAV data from the Rover.

Ok so i have just spent the day on site preparing the base and rover to test again and i have come home to find the base was not logging. WHAT IS GOING ON? All the other times it auto started and now i have just wasted a day. Can i process the rover logs to get a PPK corrected file?

Hi Steven,

If you don’t have logs from the base, you can use logs from CORS for PPK. Please note that time periods of logs should match each other.

Your base may not have started logs recording after turning on if the flag of automatic start of the logs wasn’t on. Please check this option in the Logging tab. I’ll attach the screenshot so that it’s clear.
IMG_9940

If this option is not chosen when you stop the log, the logs don’t start on the next turn-on of the unit. That’s how it should work.

If you checked the start of the log and this feature is turned on, we’d like to check why the base didn’t record the log for you. Please share the Full System Report with me in PM or via support@emlid.com. It will allow us to see the internal configurations of the unit.

1 Like

HI Thank you i have attached the report to this reply. Could you please explain how I can use the CORS data for PPK. #
Please note the box you mentioned was checked and this is the same unit i have been having battery issues with since i updated the firmware to 26.2

I am really beginning to loose heart with this and think ill just cut my losses and sell them. They are not worth the trouble.
I went to a second site to try them out again. Again the base unit was not logging when turned on (yes the box was checked) it was only when i unchecked and checked it again then pressed apply that it started (i had made sure that it was checked last night and I had pressed apply then).
When I process the base station logs i get a .pos file with nothing in it and so cant process the rover logs as I have a position for the base.
I have clients waiting for data and this is holding me up
Could someone please help the file are in the link i have sent you

Hi Steven,

Thank you for sharing the report and the logs. I’ve deleted the report from the attachments since it may contain sensitive information.

The issue with logging autostart seems quite unusual to me. Could you please share the Serial number of the unit? It is printed on the bottom of the device under the bar code. It can help us to get more information about the unit’s performance and check what might be wrong.

It looks like the CSV file you shared was downloaded from Reach Panel. Please note that the Emlid Studio supports Stop&Go with CSV files from ReachView 3 only. That’s why the error might occur.

I’ve processed the logs in the Emlid Studio 1 Beta 6. I could correct the base position fine with CORS data and use it for PPK with the rover:


Also, I tried to process the rover data using the CORS as a base station. As I see, the results are quite similar to the ones obtained with your base:

I’ve sent an archive with the results to you in PM so that you can take a closer look.

Is there a chance that you set any logs duration in the post-processing settings? In most cases, the empty .pos file indicates that there are no data for the chosen time interval. To check this, please reset the settings to default and try to process the data one more time:

If you face any difficulties, please provide me with screenshots of your settings and the logs uploaded for post-processing.

1 Like

HI. thank you for that. I not sure why it didn’t auto start logging. I have a set of log from the rover at another job, The base unit didn’t start logging so i missed the whole time I was on site. Is it possible to PPK the rover logs without the base logs but with the CORS data? if so could you please tell me how?

We are investigating why the logging autostart might not work on your Reach RS+. Would you mind sharing the serial number of the unit? It will help us to get additional information about the device and localize the issue faster.

Is it possible to PPK the rover logs without the base logs but with the CORS data? if so could you please tell me how?

Yes, it’s possible. If the distance from the rover to the CORS doesn’t exceed 30 km, you should get centimeter-accurate coordinates in such a setup. You can process the rover log directly with the CORS data in the Emlid Studio as follows:

  • Choose the PPK Kinematic mode

  • Upload the .21O log from the rover to the Rover section. In the Antenna height section, set the receiver model (Reach RS/RS+) and the measured height.

  • Upload the .21O log from the CORS to the Base section

  • Upload the .21P log from the rover to the Navigation section

  • Tap Process

Thank you. Where do i get the .21P log from. In the uk the CORS data only have the .21O file

The navigation log from the CORS is not required since you can use the .21P log from your rover unit.

The log should be automatically generated after the UBX log is converted to RINEX format. To convert UBX to RINEX, you can use the Convert to RINEX tab of the Emlid Studio:

Maybe i should have told you that iam not a PPK expert. When i try to upload the .21p file from the rover to the rover section i get this:


Is there a beginners guide because iam struggling with this.

1 Like

Ok so I managed to process the logs for this site, as it was a test I only did 5 points. I applied the CORS data got the base location them applied them to the rover. I then used time span interval (allowing for the difference between GPS and UTC time) in RTKPlot and the CSV file to to get the recording start and stop time for each GCP. but when the are put into Pix4d they are all out by about 20mtrs to the left.
207600273_566880494469694_821125438241476981_n
Yellow arrow shows where the GCP is and the blue dot to the left is where Pix thinks it is.
210123626_171458898354216_2834039178757010786_n
Both the blue dots are to the left of where they actually are.

Blow is a link to the files on google drive. Please let me know what i am doing wrong. step by step in plain English (by that i mean with pictures and as if you are talking to an idiot, because you are)

I have also taken a closer look at the base location and that to is further left than i actually is.
If this fails does anyone what to buy a Reach RS and RS+

1 Like

Ok so i have another problem then. The image below is from google maps and shows the location of the site. The red marker show the position of the base station according to your corrected file. The grey point is the area the base station was actually in based on the composite image of the site


The second image is a close up of the composite image, i have circled the location of the base station. It is not the same location and this has ment the each GCP location is off as well when put into Pix4d

The blue dote is where Pix4d thinks the gcp is according to the CSV file and the yellow arrow show where is actually is.

Please explain in plain simple English what i am doing wrong. your tutorials are not great and don’t cover the basics.
I think I need to start from the setting up of the emlid units FOR PPK NOT RTK. Then cover the data collection and correcting for CORS data.
Just so your aware i am not using the reachview 3 app. Also this problem has only got worse since the latest update and is why i want to sell them. I have lost one client so far because the data is not good enough. Please help