Help for RTK settings for using Rs2+ (base) and Reach RS+ (rover)

Dear All,
after reading the post Is it possible to use Reach RS2+ base with Reach RS+ rover?
and also other requests by users, I understand that this is a common request, so I apologise for not finding a solution by myself.

However, I am trying to set two Emlid receivers (Base=Rs2+; Rover= Rs+) for RTK using LoRa communication. Starting from my past experience with two Rs+ I am trying working in RTK mode via LoRa radio with the following settings.

Base (Reach RS2+) settings:



Rover unit (Reach Rs+) settings:




Unfortunately, I can’t see any correction passing through the base to my rover unit, I suppose the problem was in RTCM messages since Reach RS2+ has different codes from Reach RS+.

Do you have some suggestions regarding what I am doing wrong?

Many thanks for your help.

Best regards
Daniele

Has the base populated its cordinates yet , average single or manual?

Hi David,
yes the base has estimated its coordinates by average single (per 5 min).

try a different freqency above 900 , see if that helps

Unfortunately frequency above 870 Mhz are not allowed for LoRa

For more details and check some bad settings I am attaching simple reports of my units

Rover Reach rs+

Simple system report
app version: 31.8-r0
current_network:
  ip: 192.168.42.1
  security: wpa
  ssid: ReachRover:54:B8
enabled: true
mode: hotspot
base_mode:
  base_coordinates:
    accumulation: 180
    antenna_offset: 1.645
    coordinates:
      height: 49.68
      latitude: 42.36954021
      longitude: 10.91277315
    mode: single-and-hold
  output:
    io_type: 'off'
    settings:
      lora:
        air_rate: 9.11
        frequency: 868000
        output_power: 20
      ntripcaster:
        mount_point: REACH
        password: '***'
        port: 2101
        username: reach
      ntripsvr:
        address: ''
        mount_point: ''
        password: '***'
        port: -1
      serial:
        baud_rate: 38400
        device: ttyEXTS0
      tcpcli:
        address: localhost
        port: 9001
      tcpsvr:
        port: 9000
  rtcm3_messages:
    message_1002:
      enabled: true
      frequency: 1
    message_1006:
      enabled: true
      frequency: 0.1
    message_1010:
      enabled: true
      frequency: 0.5
    message_1097:
      enabled: true
      frequency: 0.5
    message_1107:
      enabled: false
      frequency: 1
    message_1117:
      enabled: false
      frequency: 1
    message_1127:
      enabled: false
      frequency: 0.5
bluetooth:
  enabled: true
  pairing:
    discoverable: false
    no_input_no_output: true
    pin: '***'
correction_input:
  base_corrections:
    io_type: lora
    settings:
      bluetooth:
        send_position_to_base: false
      lora:
        air_rate: 9.11
        frequency: 868000
        output_power: 20
        send_position_to_base: false
      ntripcli:
        address: ''
        mount_point: ''
        password: '***'
        port: -1
        send_position_to_base: true
        username: ''
      serial:
        baud_rate: 38400
        device: ttyEXTS0
        send_position_to_base: false
      tcpcli:
        address: localhost
        port: 10001
        send_position_to_base: true
      tcpsvr:
        port: 10000
        send_position_to_base: true
device:
  power_on_bottom_connector: false
  privacy_policy_accepted: true
  role: null
  rv3_banner_shown: true
  usage_analysis_accepted: true
logging:
  logs:
    autostart: false
    base:
      enabled: true
      format: RTCM3
    raw:
      enabled: true
      format: UBX
      rinex_options:
        logging_interval: 1
        marker_name: null
        pole_height: null
        preset: custom
        satellite_systems:
          beidou: false
          galileo: false
          glonass: true
          gps: true
          qzss: false
          sbas: false
        time_adjustments_enabled: false
    solution:
      enabled: true
      format: LLH
    started: false
  settings:
    interval: 24
    overwrite: true
    simultaneous_logging: false
position_output:
  output1:
    io_type: bluetooth
    nmea_settings:
      bluetooth:
        ebp:
          enabled: true
          update_rate: 1
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      serial:
        ebp:
          enabled: true
          update_rate: 1
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      tcpcli:
        ebp:
          enabled: true
          update_rate: 1
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      tcpsvr:
        ebp:
          enabled: true
          update_rate: 1
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
    settings:
      bluetooth:
        format: NMEA
      serial:
        baud_rate: 38400
        device: ttyEXTS0
        format: ERB
      tcpcli:
        address: localhost
        format: ERB
        port: 9000
      tcpsvr:
        format: LLH
        port: 9001
  output2:
    io_type: tcpsvr
    nmea_settings:
      bluetooth:
        ebp:
          enabled: true
          update_rate: 1
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      serial:
        ebp:
          enabled: true
          update_rate: 1
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      tcpcli:
        ebp:
          enabled: true
          update_rate: 1
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      tcpsvr:
        ebp:
          enabled: true
          update_rate: 1
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
    settings:
      bluetooth:
        format: NMEA
      serial:
        baud_rate: 38400
        device: ttyEXTS0
        format: ERB
      tcpcli:
        address: localhost
        format: ERB
        port: 9000
      tcpsvr:
        format: LLH
        port: 9001
positioning_settings:
  elevation_mask_angle: 30
  glonass_ar_mode: true
  gnss_settings:
    positioning_systems:
      beidou: false
      galileo: true
      glonass: true
      gps: true
      qzss: false
      sbas: false
    update_rate: 5
  gps_ar_mode: fix-and-hold
  max_horizontal_acceleration: 1
  max_vertical_acceleration: 1
  positioning_mode: kinematic
  snr_mask: 35

Reach RS2+ base

Simple system report
app version: 31.8-r0
current_network:
  ip: 192.168.42.1
  security: wpa
  ssid: ReachRS2Base:7E:4A
enabled: true
mode: hotspot
base_mode:
  base_coordinates:
    accumulation: 120
    antenna_offset: 0
    coordinates:
      height: 0
      latitude: 0
      longitude: 0
    mode: single-and-hold
  output:
    io_type: lora
    settings:
      lora:
        air_rate: 9.11
        frequency: 868000
        output_power: 20
      ntripcaster:
        mount_point: REACH
        password: '***'
        port: 2101
        username: reach
      ntripsvr:
        address: ''
        mount_point: ''
        password: '***'
        port: -1
      serial:
        baud_rate: 38400
        device: ttyEXTS0
      tcpcli:
        address: localhost
        port: 9001
      tcpsvr:
        port: 9000
  rtcm3_messages:
    message_1004:
      enabled: false
      frequency: 1
    message_1006:
      enabled: true
      frequency: 0.1
    message_1008:
      enabled: false
      frequency: 0.1
    message_1012:
      enabled: false
      frequency: 1
    message_1033:
      enabled: false
      frequency: 0.1
    message_1074:
      enabled: true
      frequency: 1
    message_1084:
      enabled: true
      frequency: 0.5
    message_1094:
      enabled: true
      frequency: 0.5
    message_1124:
      enabled: false
      frequency: 0.5
    message_1230:
      enabled: true
      frequency: 0.1
bluetooth:
  enabled: true
  pairing:
    discoverable: false
    no_input_no_output: true
    pin: '***'
correction_input:
  base_corrections:
    io_type: 'off'
    settings:
      bluetooth:
        send_position_to_base: false
      lora:
        air_rate: 9.11
        frequency: 868000
        output_power: 20
        send_position_to_base: false
      ntripcli:
        address: ''
        mount_point: ''
        password: '***'
        port: -1
        send_position_to_base: true
        username: ''
      serial:
        baud_rate: 38400
        device: ttyEXTS0
        send_position_to_base: false
      tcpcli:
        address: localhost
        port: 10001
        send_position_to_base: true
      tcpsvr:
        port: 10000
        send_position_to_base: true
device:
  power_on_bottom_connector: false
  privacy_policy_accepted: true
  role: null
  rv3_banner_shown: false
  usage_analysis_accepted: true
logging:
  logs:
    autostart: false
    base:
      enabled: true
      format: RTCM3
    raw:
      enabled: true
      format: RINEX
      rinex_options:
        logging_interval: 0
        marker_name: null
        pole_height: null
        preset: default
        satellite_systems:
          beidou: true
          galileo: true
          glonass: true
          gps: true
          qzss: true
          sbas: false
        time_adjustments_enabled: true
      version: '3.03'
    solution:
      enabled: true
      format: LLH
    started: false
  settings:
    interval: 24
    overwrite: true
    simultaneous_logging: false
network:
  tcp_over_modem: false
position_output:
  output1:
    io_type: 'off'
    nmea_settings:
      bluetooth:
        ebp:
          enabled: true
          update_rate: 1
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      serial:
        ebp:
          enabled: true
          update_rate: 1
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      tcpcli:
        ebp:
          enabled: true
          update_rate: 1
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      tcpsvr:
        ebp:
          enabled: true
          update_rate: 1
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
    settings:
      bluetooth:
        format: NMEA
      serial:
        baud_rate: 38400
        device: ttyEXTS0
        format: ERB
      tcpcli:
        address: localhost
        format: ERB
        port: 9000
      tcpsvr:
        format: LLH
        port: 9001
  output2:
    io_type: 'off'
    nmea_settings:
      bluetooth:
        ebp:
          enabled: true
          update_rate: 1
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      serial:
        ebp:
          enabled: true
          update_rate: 1
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      tcpcli:
        ebp:
          enabled: true
          update_rate: 1
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      tcpsvr:
        ebp:
          enabled: true
          update_rate: 1
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
    settings:
      bluetooth:
        format: NMEA
      serial:
        baud_rate: 38400
        device: ttyEXTS0
        format: ERB
      tcpcli:
        address: localhost
        format: ERB
        port: 9000
      tcpsvr:
        format: LLH
        port: 9001
positioning_settings:
  elevation_mask_angle: 15
  glonass_ar_mode: false
  gnss_settings:
    positioning_systems:
      beidou: false
      galileo: true
      glonass: true
      gps: true
      qzss: false
    update_rate: 1
  gps_ar_mode: fix-and-hold
  max_horizontal_acceleration: 1
  max_vertical_acceleration: 1
  positioning_mode: kinematic
  snr_mask: 35
sound:
  mute: false
  volume: 100

Hi Daniele,

I’ve checked the simple system reports. Thanks for sharing them!

Is there a chance that you configured your Reach RS+ as your base under Base settings? The base’s coordinates seem to be tied to it and not to the Reach RS2+.

If so, let’s reconfigure the setup and check if you can establish the communication over LoRa this way.

Dear Kornel,
many thanks for your reply.

Under 'base settings" of my reach rs+ unit I have set the following so let me know how if I should configure it differently.

Whilst I noted that GNSS settings menu is a little bit different between ReachRs 2 Reach RS+. Conversely the Reach rs+ seems to have more options available but maybe I am missing something.

Reach rs 2

Reach Rs+

Hi Kornel,
just a brief update to inform you that I finally got success in RTK connection between the two units achieving in few minutes a fix solution as you can seem in the attached screenshot. I think that my problem relied in RTCM messages since I erroneously anabled SBAS in just one unit.
I also tested Ntrip connection via mobile hotspot and it works like a charm.
The RS2 is really impressive and I was indebted to you for providing such great help and support when decided to replace my reach RS+. So many thanks again !