Has anyone got Ntrip using CRTN base stations to work?

I have been trying to get NTRIP to work on an RS2 in in Northern California using the CRTN network.

I can log on to the network and see the mount points but when I try to access the corrections I just get a message in Reachview 3 that the reach is “waiting for corrections”. No matter how long I wait there are no corrections arriving.

I have seen some other posts from a few months ago where other people were having trouble with this and EMLID thought it was a problem with this particular server.

Has anyone figured this out and got it to work yet?

Do you know what RTCM messages they are putting out?

It is RTCM3 format.

Can you use SNIP to view the messages and post a screenshot like the one I have here.SNIP messages

This is the Ohio CORS network messages.

If you do not know how to do that, you could PM me your NTRIP connection information, username/password/ip address and mountpoint and I could do that and post it for you. Being in Ohio, I assure you I have no need for California CORS and will keep your login info confidential.

Hi @hydrokiwi,

There are indeed some difficulties with the CRTN network. Some mount points are working fine, and the others are not. They provide needed RTCM3 messages, and we’ve checked a lot of logs from other users. However, we don’t see any obvious reason for this behavior. We’ve tried to contact them to figure out what might be wrong, but there are still no results.

For now, I’d recommend checking other available networks.

Hi Svetlana

Thanks for your reply.

With some help I was able to get a SNIP log of the messages sent from CRTN.

Does this help?


SVIN (002)

Hi John,

Reach RS2 supports these RTCM3 messages. It also corresponds to the Reach RS2 minimal requirements: there are ARP station coordinates (1006) and GPS observables (1004) messages. By all accounts, there should be no issues with this caster. That’s why we’re still investigating this.

It looks like CRTN just doesn’t output enough data for Reach RS2 to calculate the solution. It would be helpful to find out what GPS and GLONASS signals they track. Reach RS2 works with GPS L1C/A, L2C, and GLONASS L1OF, L2OF signals. If you know anything about that, it’d be of great help because I couldn’t find any info on their website.

I noticed their message rate is very slow. Not sure on the L1/L2 is that info in one of the messages? I can view the raw message data.

I have sent CRTN an email asking for more information about their stream but so far I have not had a reply.

Hi guys,

Thank you for your help!

Is it possible to download this data somehow? It might be useful to check.

I have the free version of SNIP, I really haven’t looked into the logging side of it to see what is available. If it can, I would be happy to. I know you want messages 1004/1012 at a higher rate for any system but I thought the 1006/1007 rate was extremely slow if you look at the table hydrokiwi posted. 1004/1012 are getting data 15 times more than 1006/1007

I guess you saw this basic information on the CRTN website.

They also say they broadcast corrections at 1 HZ which is fine for general survey work.

They also say that since 2018 their stations are referenced to a new California Geodetic Datum CSRS Epoch 2017.50 (NAD83). http://geoweb99.ucsd.edu/index.php/epoch2017/. I dont know whether there is a problem in using this datum or whether the datum would affect the Reach’s ability to use the corrections.

I have not heard back from them by email. With Covid things are not normal.


I prefer 5 Hz as I do topo mapping at 20 MPH with my Trimble unit.

Hi there,

1006 and 1007 messages contain ARP station coordinate. This info usually doesn’t change, so the rover doesn’t need frequent updates from the base. For example, with Reach RS2 base, we suggest setting the update rate for 1006 message to 0.1Hz, while for other messages, it should be 1Hz.

Yes, it indeed should work fine. Also, Reach supports the NAD83 coordinate system. It shouldn’t affect getting a Fix.

So, if you receive any other info from the caster, please let me know. We’ll continue the investigation from our side as well.


Here is the reply I got from CRTN.

In addition I tried recording the data stream.

Here is the log file. It is for the mount point SVIN_RTCM3 in California Zone 3.

Svin Log File.log (14.3 KB)

I see the log references Geodetics CommLinkProxy Version 3.5 EV

Products | Geodetics

Does this help?


Hi John,

Thanks for sharing this! I need a bit more time for additional research. I’ll post all my findings here.

Hi there,

Just wanted to let you know I’ve written to the CRTN support but haven’t received any reply so far. I’ll let you know if there any news.


I installed the new 26 firmware on my RS2 and still cannot get corrections from CRTN in California via NTRIP. It still just says “Waiting for Corrections”.

Did you try contacting the company Geodetics which supplies their system software. I put the contact data for them in a previous message on this thread.


Just a note here – I am also in Northern California (Lake/Mendocino/Sonoma/Humbolt county areas) and have had success getting high-frequency (1 Hz) NTRIP updates into my REACH RS2 rover via cellular data / SIM card, using several different UNAVCO NTRIP mount points.

Read more here; you will need to request user access, I was able to obtain it after just a day or two.

Info about the UNAVCO gnss services. (Request access by sending them an email.)

Map of UNAVCO CORS locations. (Be patient – for some reason this page sometimes takes minutes to load…) https://www.unavco.org/instrumentation/networks/status/all/realtime


That’s good to know.

There are CRTN and UNAVCO points in the same network.

I have a logon and have used it on other equipment.

Not sure why it is not working.