Gyros still settling/Inconsistent Compasses


I have two navio boards. One is working fine when I arm it, and the second is consistently giving an pre-arm check error:
Gyros still settling

This error stays for a long time (without moving the drone as needed to settle the gyros), then I am able to arm for some time. After some time, it stops arming with the same pre-arm check error. I tried to restart and always the same problem.

In ground station, yaw, roll and pitch are fixed and do not change when we move the drone.

Note that I did all kind of calibrations.

Any help on this matter


Could you please enable disarmed logging and share logs with us?

What I actually did is that I made a new installation of the image and ardupilot.
Now, I am not having any more the consistent problem of
Gyros Still Settling
But I got problem with Inconsistent Compasses.

So, I disable Compass2 and now I am not having that error anymore and looks to be working.

But I am not sure how to work with both compasses without having inconsistency.

I noticed that during the calibration of the Compass (when both are enabled), I see only one compass during calibration and not two, is that normal?

right now ardupilot only uses 1 compass for navigation, so you will be fine with disabling one compass;

that inconsistent compasses message is related to your uncalibrated compass; try onboard compass calibration for each compass one at a time; (disable one compass - reboot - calibrate - disable the other compass - reboot - calibrate - enable both - reboot; (it worked best for me);
after that your compass should be fine! but the 2 compasses only have the use of warning you in strong strange magnetic field - at least at the moment!

Thanks for the tips. It is useful.

I will try it, although I think I will try to manage working with one compass.

I think such information should be made clear in the documentation. It lost me a lot of time.

1 Like

Just to mention that working with only one internal compass solved the problem.
I used Compass 1 as Primary Compass with no problem