GStreamer on new setup

Navio2 Raspberry Pi 3 Model B Raspberry Pi Camera

Having difficulty setting up the camera to stream video to GCS. Can connect to both QGroundControl and Mission Planner. Basic setup done in QGC. Neither get video streaming.

Have no idea really where I’m at with GStreamer. Have a copy on my laptop. Pretty sure it’s on the Tablet also. Have followed the setup for raspberry pi and looks like the video can stream out - pipeout. Because of the issue with the keyboards not allowing certain character sets i used Putty to access the raspberry to make the changes. But nothing happening with the Tablet or Laptop when connected. I thought because the setup for an android device looked the easier of the two I would use it. But nothing. Have tried to run a file, like described in the Docs, for the PC. Nothing doing. Just too many variables to get absolutely correct!

I’m kinda lost. I’m only connected to the home network and don’t even know if i can stream to the other devices. Not sure on the frequency. I think it matters. I will be trying to source some telemetry radios and see how that goes or some other wifi. I have tested the camera and can take photos and can record video.

But honestly, I am saving for the Edge (Wish I never got the Navio2 right this minute).

Any one have any suggestions?

I thought the Navio2 was going to be kinda plug-n-play.


First it failed
Then…

and then…

Sorry if I come across as being a bit negative. I’m very surprised and dissapointed that this has been so difficult to setup., Considering it basically hardware which i thought would come configured and just need everything to be attached and tuned then go flying. :frowning:

Ok. Thanks. I’ll try that.

I am still having no luck with gstreamer. Still no luck viewing a raspi camera on either QGroundControl or Mission Planner. Can connect to them ok, but I don’t get a video. I’m not sure what the files are ment to be for windows and android.

I created a batch file for windows. Was I suppose to do that? I saw a young girl do that on youtube. She used raspberry pi but not anything like what I’m trying to do with a Navio2, unfortunately.

Then there is the downloading for gstreamer. What are we ment to do there?

I think i read that the latest version of raspberry pi has gstream 1.1, or something. Whatever it is I can’t update, download, install or do anything.

Everyday that passes I wish I never bothered with this. DJI flight controlllers - Work. Your new Edge would have been nice. But no, i had to opt for the Navio2 with is far from plug-n-play. What was I thinking!!!

Normally a flightcontroller involves setting up/tuning the firmware. The Navio2 on a Raspberry is another level, because you need to learn basic linux command line usage, basic networking and how to setup a vehicle using ardupilot. If you add things like gstreamer, wifibroadcast or ROS, things can get even more complicated.
The Emlid guys came a long way making the whole setup more user friendly, but there is still a learning curve. I have a working gstreamer setup, which I use to send video to qgroundcontrol on my smartphone or tablet. Qgroundcontrol does not require any additional software to receive the video, you just have to set it to receive the right protocol. I did not try to receive video with qgroundcontrol on my PC yet, but I will try later.
I will post my gstreamer pipeline and the settings for qgroundcontrol as soon as I get in my workroom.

1 Like

Probably not that big a deal now.

I’ve since managed to stream video to QGroundControl, and yeah the instructions do allow you to do that when followed. At the time it was just like a new language for myself. The main issue I have now is getting EZ-wifiBroadCast to work.

I’ve been looking Online at some forums and the DOCS here at EMLID for information on how to setup EZ-wifiBroadCast. Emlids instructions are pretty clear (still doesn’t provide myself with a working FPV setup). Not sure how I’m suppose to do the Rx commands when as soon as you turn the Raspberry Pi that’s acting as the Rx you get mentions about an error where no wifi can be found - even thought you have connected a wifi module you saw on the forums as having been tested and shown to work. But I will say that I am using a version 4 and not the version 2 they mentioned. But other than that it’s the same model. Tomorrow I’m going to try to get the exact one from the forums and see it that helps. The whole idea of doing this, using Navio2 with Raspberry Pi 3 Model B, Pi Camera, EZ-wifibroadcast & QGroundControl was so that I could have something that would match the Shop-bought Drones that offer all that.

Forums I have visited (which if you believe what they say should provide you with a working model) have been github and RCGroups : https://github.com/bortek/EZ-WifiBroadcast/wiki and https://www.rcgroups.com/forums/showthread.php?2664393-EZ-WifiBroadcast-cheap-digital-HD-transmission-made-easy!
plus as many videos I could find on youtube.

I didn’t want to mess about with power supplies to try and see if the wifi cards will then work. When I plug them into my Desktop PC they work fine from it’s USB. When I plug them into the USB port on the Raspi with the Navio2…nothing happens. Same with the Rx Raspi. Nothing. I’m using the power module supplied by Emlid with a 3S 6000mAh Lipo. I looked into EZ-wifibroadcast files and the power output is = 1, so I’m guessing power should be enough for a usb wifi that runs on a desktop pc usb. ?? who knows.

I would have thought that all this should have been pretty simple stuff. Far from it, really.

Still wishing I never bothered with this.

Manufacturers sometimes use completly different chipsets between revisions of the “same” product. Since wifibroadcast uses special abilities of those dongles, it is a good idea to use the exact model they mentioned.
How do you come to the conclusion that “nothing happens”. The LEDs on the dongles I own, behave differently under Windows and Linux.
Did you try and type “dmesg” in the command line?
Is the wifi dongle listed there?
If you plugged it in after boot up of the Raspberry Pi, it should be one of the last entries.
I sometimes use 2 wifi dongles and a wireless keyboard/mouse receiver at the same time, without a problem.

The problem I’m having is EZ-wifi doesn’t see a wifi device when it first starts up.

I do have a question. With two Raspberry Pi, one for Tx and one for Rx I download the latest Emlid Raspbian Image, this will be the Tx side with the Naivo2 and Camera etc etc. Then I download the EZ-wifiBroadCast and install that and load that onto the Rx Raspberry Pi. Correct? Thing is, what is this:

Receiver setup¶

To start broadcast on receiver:

sudo systemctl start wbcrxd
Transmitter setup¶

To start broadcast on transmitter:

sudo systemctl start wbctxd

If i enter this:
sudo systemctl start wbcrxd
wbcrxd.service failed to load: No such file or directory.

This is what I mean? You want people to use this product but there aren’t any clear instructions on how to use it.

I did the dmesg command and got the above. It is reading the wifi USB. Same goes for the Rx Raspberry Pi. Doesn’t change anything. Still doesn’t work.

I will download and install this, BETA version (anemos fork based on Stable v1.2): EZ_wbc_anemos_modified.v1.2beta.zip to my card and run it again. See what error message comes this time.

Now have two ALFA wifi adapters. Model AWUS036NHA. I’ve connected to the Navio and entered in sudo systemctl start wbctxd. I have turned on the Rx Raspberry Pi with the other adapter attached and started that. Looks to be fine but no video is displayed and no dbi readings, except for it being 0.

I’ve followed the few instructions there are on this site. I’m now trying to find information on the forums. Very frustrating when you supposedly have the right equipment and follow what instructions there are and the stuff still doesn’t work.

What is the price of a micro usb card? $5?, $10? I’d like to see a “WORKING” card included with the Navio2 when you purchase one. Just so when you power it up with actually does all the thing the Website claims it can do. Then if I want to tweek it I can, after I see everything is working.

Do we need to change the frequency on the Navio2? The EZ-wifibroadcast has a frequency already setup. In my case it’s 2472MHz. What the frequency on the Navio?

https://docs.emlid.com/navio2/common/dev/wbc/

Followed the steps here. Now what?

This topic was automatically closed after 100 days. New replies are no longer allowed.